Tropical Fish Keeping banner

1 - 5 of 5 Posts

·
Registered
Joined
·
558 Posts
Discussion Starter #1
I just got some Water Sprite (Ceratopteris Cornuta) through ebay. It was in the mail for 3 days, and arrived with quite a few brown leaves. I put the mother plant in one tank and a baby each in another tank, and the quarantine tank. My PH is 8-8.2. I've had no luck with Hornwort, java moss, Christmas moss and Flame moss. I do fine with Java fern, Italian Val, mini swords and one or two others. Oh, Frogbit died on me too.
Too much current, I think. Also, my lighting is standard that the tanks came with, so not particularly high.
I got Water Sprite because of its good reviews and tolerance.

I have trimmed all the brown off the plant, and now its only half as big. I will attach a pic of it before I trimmed it. Do you think it will grow for me? I didn't acclimate it--didn't realize you had to do that with plants, and I bet my PH is a lot higher than where it came from. Will that kill it? I've never had this plant before, and would really like to have life floating plants for my fish instead of the yucky fake ones that I've been having to put up with.

Water Sprite.jpg
 

·
Registered
Joined
·
558 Posts
Discussion Starter #2
Forgot to add the pic of it now that its been trimmed. Not much left....Cut about 2" off the roots--seems to have a lot. They look black in the pic, but they're actually dark green. Hope that's a good sign.

Trimmed Water Sprite.jpg
 

·
Registered
Joined
·
1,265 Posts
That looks like the potted version of water sprite, not the kind meant to float :/

I think it can eventually re-orient itself to the light, but from my own experiences/thread on the matter they're actually two different plants.
 

·
Registered
Joined
·
2,388 Posts
That looks like my floating water sprite. It should do fine. Just baby it for a while. Mine came potted and had to go through an adjustment period. One thing to make sure of is that the leaves stay in the light. Sometimes the current will push the plant so the leaves aren't getting any light. This happens a lot in my higher-current tanks.
 

·
Registered
Joined
·
558 Posts
Discussion Starter #5
Thanks--it isn't a high current tank, and its on the opposite side of the tank from the filter, and hasn't drifted at all. Maybe it'll come through after all. I'm reading now that some people have trouble growing it, yet others have it all over the place!
 
1 - 5 of 5 Posts
Top