Tropical Fish Keeping banner

1 - 4 of 4 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter #1
Okay, so I got the Magnum 350 hooked up and running and I want to rinse off the cartridge. So, while the filter is still running I turned off the inlet valve, thinking this will lower the level in the filter so I can remove the top. Nope, it just stops filtering, but the canister remains full of water. That doesn't seem right, because when you close both inlet and outlet valves and remove the top, you're going to have water all over the place. What I did was remove the inlet tube from the tank to break the vacuum and the filter then pumped out enough water that when I removed the top there was no water going all over....I've read the instructions, and can't find any information. I KNOW I gotta be missing something pretty simple.....Can someone explain this to me?

Thanks
Never Quit
 

·
Banned
Joined
·
4,058 Posts
Do you have the double quick disconnects on the filter? If you don't, those are what you are missing, in order to service the filter. You turn off filter, close the 4 valves on the disconnects, then twist the disconnects and pull apart. Take the filter assembly outside and rinse.
 

·
Registered
Joined
·
68 Posts
Discussion Starter #3
THANKS! Yes, I do have the double quick disconnets installed. I just ASSUMED you removed the top to access the cartridge...And, as I said in my note, I gotta be missing something pretty simple. Yeah, it was one of those things that was SO OBVIOUS I overlooked it.

Thanks, I appreciate it
Neve Quit
 

·
Banned
Joined
·
4,058 Posts
THANKS! Yes, I do have the double quick disconnets installed. I just ASSUMED you removed the top to access the cartridge...And, as I said in my note, I gotta be missing something pretty simple. Yeah, it was one of those things that was SO OBVIOUS I overlooked it.

Thanks, I appreciate it
Neve Quit
Right on.:thumbsup:
 
1 - 4 of 4 Posts
Top