Tropical Fish Keeping banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
so i decided to dig out my 60gallon tank and set it up in my son's room for him, i have had the tank running for just under a week, it has a undergravel filter with 2 powerheads and a HOT Magnum 250.
we bought some new decor from petsmart and i reused some from a past tank i had. i now have this algae(i think?) i took lots of photos let me know what you think it is!

http://s666.photobucket.com/user/Rya.../library/algae
 

·
Registered
Joined
·
1,661 Posts
so i decided to dig out my 60gallon tank and set it up in my son's room for him, i have had the tank running for just under a week, it has a undergravel filter with 2 powerheads and a HOT Magnum 250.
we bought some new decor from petsmart and i reused some from a past tank i had. i now have this algae(i think?) i took lots of photos let me know what you think it is!

http://s666.photobucket.com/user/Rya.../library/algae
I'm guessing the beginning of hair algae. Not good stuff too have. May sort itself out as your tank matures. It's usually caused by an imbalance of light and nutrients. I'm not good about causes of algae. :oops:
 

·
Registered
Joined
·
211 Posts
That isn't hair algae I don't think.. Is the tank cloudy ? That stuff is the just from the cycle process its actually just bacteria building up (a good sign).. It will go away in 2-4 weeks. Just do daily water changes 15-25% water, and make sure you use prime water conditioner if you have city tap water with chlorine in it.. If you have fish in the tank deff do water changes to keep the ammonia and nitrites from the cycle process from killing them.. Do you have an API master test kit ? They can be kinda pricy but SOO worth it.

You can get some API Suplimental bacteria from Petco or Petsmart and use IMO 2x the recommended dose to help speed up the cycle.. Also adding food in the tank to create ammonia for the bacteria to eat and spread in the tank faster is a good idea too
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4 (Edited)
I have a test kit, but I lost the card and instructions for it, also the tank is crystal clear. There are no fish in the tank yet
Posted via Mobile Device
 

·
Registered
Joined
·
211 Posts
You don't need the instructions.. The other bottle you gatta shake is the Nitrate #2 bottle.. shake it like crazy for 30 seconds, and then shake the tube for 1 minute.. don't use the caps to hold the water when you shake them as stuff leaks out use your fingers rinsed in the tanks water.

My betta tank has the same clear stuff growing on stuff in there.. Itll go away... Now if it is hair algae and its only on the driftwood.. I am unsure what to do about that stuff because I have never had it
 
1 - 5 of 5 Posts
Top