Tropical Fish Keeping banner
1 - 9 of 9 Posts

·
Registered
Joined
·
763 Posts
Discussion Starter · #1 ·
i did some reading and it finally occurred to me why most of my plants are doing so poorly and my fish so well my nitrate level is v-low how do i introduce nitrate to plants without upsetting the fish
 

·
Registered
Joined
·
5,394 Posts
Out of interest, how low are your nitrate readings?
 

·
Registered
Joined
·
21 Posts
Like asked, how low are your Nitrates? I found that anywhere from 10-20 ppm is fine for my plants. If it is real low try Greg Watsons Dry Ferts. They have Potassium Nitrates(KNO3) and it will raise your nitrates for the plants.
 

·
Registered
Joined
·
81 Posts
I wouldn´t just blame it on the No2 level. Plants grow with a low nitrate level as well. At least my plants did with a 5 mg/l level and below.

There might be other things to consider before adding something to the tank:

CO2 vs. O2
Fe level
Species of plant vs. appropiate amount of lightning

...
 

·
Registered
Joined
·
21 Posts
Sleepy said:
I wouldn´t just blame it on the No2 level. Plants grow with a low nitrate level as well. At least my plants did with a 5 mg/l level and below.

There might be other things to consider before adding something to the tank:

CO2 vs. O2
Fe level
Species of plant vs. appropiate amount of lightning

...
I agree. You shouldnt blame it on just Nitrates but I had noticed that when I dosed just the other nutrients minus NO3 then I had plant problems. Now dosing NO3 again I am seeing much better health in the plants, even my High Light plants that are doing great.
 

·
Registered
Joined
·
763 Posts
Discussion Starter · #7 ·
about 4-5ppm i'm relating this to another post that refers to the appearance of green spot alga which is apparently broght on by low nitrates the only plant thats doing well(very well)is the crypts the other plants are not dying there just not doing anything full stop the crypts are using fertiliser sticks alough the were doing just as well without using a simalar system on the other plants would be difficult as they are mostly java ferns not grown in the substrate
 

·
Registered
Joined
·
2,866 Posts
Green spot algae, the really hard stuff is usually caused by a shortage of phoshpates or at least it is in my tanks.

The growth rates could very well be caused by low nitrates. Readings under 5ppm can often be closer to zero 0 because of the nature of the test kits. I would dose it and also make sure that you are dosing the other needed nutrients as well. Once the plnats get the nitrates they need they will go through others faster also and you may see other deficiencies.

What do you dose now?
 

·
Registered
Joined
·
763 Posts
Discussion Starter · #9 ·
ive removed the plants that were doing poorly which was only really the javas and moved them to the livebearer tank the rooted plants are dosed with a 6 month slow relese fertiliser sticks and apart from the spot alga on the leaves there groth rate remains good im still on the lookout for a lily type plant which will fill up the room left.
its odd that i can grow houseplants to monsters, have never lost a fish to disese or ignorance of care, bred numerous species but-------------getting both to work in the same place is a not an easy one
 
1 - 9 of 9 Posts
Top