Tropical Fish Keeping banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I set up my new 90g tank about 5 months ago. I have sand, a coral rock and a piece of driftwood in there. I had it running with the filter for about a month and then I added a few feeder fish. Within a week they all died. I kept the tank running for another month doing a pwc of 20-30% every two weeks. I then added some tiger barbs n a catfish n they were fine. When I did the next pwc they started dying about an hour later. I checked the pH and temperature and it was fine. The water I put in was the same as the one already in there. The. I started getting a lot of diatoms even though I started doing weekly pwcs. After two months of that without fish I did a 50-60% pwc n the diatoms stopped. I've had live plants in the tank for about 6 weeks now. The pH is at 7.6. Ammonia nitrate and nitrite are at 0. The water is soft. These parameters have been constant for over a month. I just put in some new fish. A few goldfish. A few mollies. And two plecos. One of the mollies already died. Another is floating at the top. And one of the plecos is not looking good. I don't know what to do
 

·
Registered
Joined
·
9,426 Posts
hello and welcome.
do you have any friend with aquariums ? if you do ask the if they would
please donate some filter media to you,add it to your tank,and that may help
the fish...or return all the fish and cycle the aquarium using Ammonia from
a hardwear shop.http://www.tropicalfishkeeping.com/beginner-freshwater-aquarium/important-topics-257/
have a look in here,there's all the information you'll need...if you have any problems
getting through it all lol as there is much to read, just ask :-D
 

·
Registered
Joined
·
679 Posts
What have you been using to get rid of the chemicals in the tap water? A lot of it has chloramine and simplly aging it will not get rid of it. It may weaken it to be less toxic, but it will not clear. It sounds like you have a water issue and I would suspect if it is not chloramine than you have something toxic in the tank. Don't know where you got the driftwood or other stuff, but that is not normal. You can try testing the bottom and middle water and see if the readings are different. Use a piece of air line tube as a siphon. If you have a water softener, that could be the problem. Many of the salt mixtures have added chemicals and they linger in the system. In some cases you can't get rid of the stuff so you have to get rid of the water softener and start over allowing the chemicals a few weeks to leach out of the pipes in the house.

Let me know if any of this helps.
 

·
Reference Team
Joined
·
1,000 Posts
I second henningc's question about water conditioner. You want something that removes chlorine/chloramine and detoxifies ammonia. Prime by Seachem is most ofter recommended.

I second Wilow's suggestion that you do a fishless cycle using "pure' ammonia (that does not foam when you shake it). Try Ace hardware (Janitorial Strength). Also available online from Dr Tim (expensive).

The reason I agree is that, if you want to heavily stock you tank right away, you need a large colony of nitrifying bacteria to handle the bioload.

Alternatively, you can try Tetra Safestart. ATM Colony, API Quickstart, Niteout. These contain the nitrifying bacteria you need to eliminate ammonia and nitrite.
 
1 - 4 of 4 Posts
Top