Tropical Fish Keeping banner

1 - 4 of 4 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
I didn't know where to post this in the other thread or here. I haven't aquascaped or added anything to disturb the sand in almost 3 days now..and my water is still cloudy. In fact, it seems a little cloudier today than yesterday. All my powerheads are pointing slightly upward, so I'm not sure what's disturbing the sand. Since this tank was bigger, I did add a little more sand to keep it a DSB, but i thought it would have all settled by now.
My nitrate's around 20, cal is 400 and alkalinity is 10. I'm still working on getting those up.
I'm also not sure if my skimmer is working properly. Today's the first day i emptied it and it had the bubbly gooey stuff in it. It usually has some sort of clay stuff in it..not sure if this is floating sand that catches in it or what. I don't know if I need my cup set up high or low.
Heres some pictures





 

·
Registered
Joined
·
42 Posts
Discussion Starter #2
Now that i think about it, maybe this is solely from curing the LR in my tank. So maybe this is normal until the rock cures?
 

·
Registered
Joined
·
42 Posts
Discussion Starter #4
It's got 4" of sand all the way around, 75 lbs of dry rock and about 11 lbs of live rock (uncured). I'll turn off the powerheads and leave the skimmer on and see if it settles. I just have 2 powerheads and theyre not pointing at the sand lol.
The last tank didnt take this long to clear up. The water smells fine-the rock itself stunk though when I swapped tanks.
 
1 - 4 of 4 Posts
Top