Problems with Eclipse 1 - Tropical Fish Keeping - Aquarium fish care and resources
LinkBack Thread Tools
post #1 of 4 Old 07-25-2008, 10:24 AM Thread Starter
New Member
Problems with Eclipse 1

I am cycling a 10 gallon tank with a Eclipse 1 system 12. My family has had this tank since 98. We have replaced the light once but we have never replaced anything else.The power went out one night in a storm and the filter had to restart. It made clicking noises until it restarted. Then it started flowing out of the back of the tank. It seems as if the intake for the filter is pumping way to much water for the littler well to hold. Whenever i open the light hood thing to feed them it overflows. I think the filter is just dieing. If any one has ever had any thing like this happen, do you have any advice?
Max77 is offline  
Sponsored Links
post #2 of 4 Old 07-25-2008, 12:56 PM
aquakid's Avatar
One Thing Is You should make sure you filter pump is in the right place
then you should change your filter media
also the clicking noise is just the filter priming since it is self priming
aquakid is offline  
post #3 of 4 Old 07-25-2008, 04:05 PM
okiemavis's Avatar
I'd take it apart and clean out all the parts. It sounds like something may be clogged which isn't allowing water to flow back out at the rate it's supposed to. Hopefully when it restarted it just knocked something out of place or sucked up something which is now causing a clog.

If that fails, well, I guess it depends how in-depth you want to get, you could probably find a diagram of all the parts online and go through and figure out if any of them are broken.
okiemavis is offline  
post #4 of 4 Old 07-25-2008, 05:50 PM Thread Starter
New Member
Thanks for your reply. I went ahead and got a new filter and a lighting hood. I got a Whisper 20i in tank filter. Is this a good filter
Max77 is offline  

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Forum Replies Last Post
Eclipse System 6 Tyyrlym Aquarium Products Reviews 4 02-11-2010 08:23 PM
Temp problems/Fin Problems? eelz212 Tropical Fish Diseases 9 07-29-2008 10:26 PM
Problems problems Problems and i explain everything xxthrwitdwnxx Tropical Fish Diseases 12 05-10-2007 12:44 PM
Eclipse 12 ILoveMyKids Beginner Freshwater Aquarium 12 03-22-2007 04:10 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome