I'm Lost
Tropical Fish

Tropical Fish Keeping - Aquarium fish care and resources » Freshwater Fish and Aquariums » Tropical Fish Diseases » I'm Lost

I'm Lost

This is a discussion on I'm Lost within the Tropical Fish Diseases forums, part of the Freshwater Fish and Aquariums category; --> I have a 29G tank with a sand substrate and artificial plants with a marineland c220 filter and air stones. Tank temp is 76-78. ...

Check out these freshwater fish profiles
Thick Lip Gourami
Thick Lip Gourami
Discus
Discus
Reply
Old 06-17-2013, 10:05 PM   #1
 
I'm Lost

I have a 29G tank with a sand substrate and artificial plants with a marineland c220 filter and air stones. Tank temp is 76-78. In it are 10 pearl danios and 2 Corys. My tank has been up and running about 9 months.

Anyway, this is the second time that I have attempted to bring in a BN Pleco. And the second time that I have lost it in a matter of days.

So far my water parameters are: PH 6.8-7.0, ammonia 0, nitrite 0, nitrate around 20. I purchased two corys this time with the pleco, and the corys appear to be doing just fine.

I am just at a lost right now as to why I have been unable to keep a pleco. I did the drip acclimation method (3-4 drops/second). I replaced 1/3 of the water and cleaned the substrate before I purchased the fish.

I just dont know what to do. I love plecos and I would dearly love to have one. But I obviously cant keep buying them just so they would die in my tank. I trust the store that I got my fish from and all of my fish have come from them. I do not believe they are the issue.

At this point I dont even know what to ask. I think I just need to vent my frustration. Thanks.

-Manny
pinoyman is offline   Reply With Quote
Old 06-17-2013, 10:24 PM   #2
 
KPainter's Avatar
 
What are you feeding it?
KPainter is offline   Reply With Quote
Old 06-17-2013, 10:40 PM   #3
 
Quote:
Originally Posted by KPainter View Post
What are you feeding it?
What I've been feeding my fish are the tropical flake frenzy food mixing in some vegi formula flakes and I drop a couple of sinking wafers for my corys once or twice a week.

There are plenty of algae for the pleco to eat as well and I noticed the spots on the glass where it has been, so it was eating. Just it dying 2 days after taking it home has me really confused.

I need to make a correction. On my OP I mentioned I have pearl danios, I actually have zebra danios. I know there is a big difference in sizes between the two.

Last edited by pinoyman; 06-17-2013 at 10:44 PM..
pinoyman is offline   Reply With Quote
Old 06-17-2013, 11:04 PM   #4
 
KPainter's Avatar
 
What are your water parameters?
KPainter is offline   Reply With Quote
Old 06-18-2013, 10:29 AM   #5
 
1077's Avatar
 
I would wonder if the fish you are buying are newly arrived fish (at the store), or have been in the store for a while. Might try and wait a few day's to a week if the fishes have just arrived at the store.
Would also not add anything to the water in the way of salt,med's,or additives to influence pH.
Drip acclimation is wise.
Might also try another source for this fish andsee what happen's.
Could be something the fish store is adding to the tank that makes your water totally different and fish are struggling to adapt to the change.
Might also try and get larger specimen than the tiny two inch fish I see offered at some stores.
Healthy specimen's bellies will look full as opposed to concave(sunken).
1077 is offline   Reply With Quote
The Following User Says Thank You to 1077 For This Useful Post:
pinoyman (06-20-2013)
Old 06-18-2013, 12:30 PM   #6
 
As Plecs have a habit of feeding at night and being unobserved, they might be eating the plastic coverings on the artificial plants. If the plants are a cheap import from China - this could be the problem. Remove them and see what happens.
Jarowa is offline   Reply With Quote
The Following User Says Thank You to Jarowa For This Useful Post:
pinoyman (06-20-2013)
Old 06-20-2013, 11:12 PM   #7
 
Thanks for all the replys.

The first pleco I purchased was about a month ago. It died about a week soon after. I then waited a month and purchased the last one, which died just 2 days after.

My water parameters have been very good, PH 6.8-7.0, ammonia, nitrite are at zero nitrate around 20.

I did not think about the plastic plants. I think I have good quality artificials, got em from Drs. Foster and Smith. But I will remove them and see.

I do not add any chemical to the tank other than Prime when I replace the water after cleaning.

My resident zebra danios and the 2 corys that I purchased together with the pleco is currently doing well. The guy at the store decided to actually give me a bigger corys because they will deal better with the change. Even the pleco he gave me this time was bigger.

The only other thing I can think of that could cause a issue would be the substrate, I use play sand. But if there was a problem with the sand, then the cory's would probably have already died as well.
pinoyman is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
I am Lost, PLEASE HELP hunterg17 Beginner Freshwater Aquarium 41 03-02-2013 07:05 AM
I'm lost... no really Night Foxx Beginner Freshwater Aquarium 8 12-02-2009 02:35 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -5. The time now is 01:09 AM.