Help Tiger Barbs acting weird - Tropical Fish Keeping - Aquarium fish care and resources
 
LinkBack Thread Tools
post #1 of 3 Old 06-16-2011, 02:04 AM Thread Starter
New Member
 
Help Tiger Barbs acting weird

my tiger barbs have been acting weird i just redid my tank and let it run for about 2 weeks its a 55 gallon tank
then i added new fish 6 barbs and some other fish forgot the names but as far as i could see 2 tiger barbs have died and the others seem to be swimming aimlessly and running into things whats wrong with them????
krnxboyxjoe is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 06-16-2011, 07:58 AM
Member
 
Inga's Avatar
 
Sounds to me like your tank is cycling. What are your water parameters? I would start by doing a 50% water change and adding a good quality water conditioner like PRIME. I would do this ASAP

Do you have any live plants in your tank? If you are intending to do live plants, I would add them right away as well.
Inga is offline  
post #3 of 3 Old 06-24-2011, 05:41 PM
New Member
 
Neon Rosy with injured fin?

Ok ... Woke up this morning and found my Neon Rosy Barb somewhat swimming in a counterclockwise circle patterns. Not really swimming upright, had a slight tilt, but was at the bottom of the tank. Took a closer look and it is not moving it's left pectoral fin much, I can't tell if it's been nipped or injured ...it looks smaller/thinner than the other .. all other fins are fine.

I left around 11am It was in a bucket with aquarium salt. Get back about 4:30pm and find it;s swimming fine .. not in erratic circles or anything. Right now got him in a mini tank with an air-stone and tank substrate .. to keep an eye out. Will do PWC's from the main tank every few hours with the salt.

5 minutes after first put in the mini tank ... it made a dash for the surface and spiraled back down to the bottom ... swimming erratically like it did before and then back to swimming normally .. all within 10 seconds. The fin I thought was injured appears better?... tough to tell .. not using it as much as the other .. but more than before. Figure I'll keep checking on it for the next few days .. maybe a week, see if it develops anything new. I'm perplexed ... as much as I'd like to put it back in the main tank ... I've no idea what was up with it this morning.

The other fish are fine .. any thoughts?

EDIT - Opps ...meant to start my own thread ... Sorry.

75g FW Cyprinidae Tank - Running Fluval 404
5 BlackRuby, 4 Albino Tiger, 4 Odessa, 3 Tiger, 2 Green Tiger, 3 Denison, 2 Cherry, 2 Gold, 2 Checkered BARBS + 4 Zebra Danios, 1 Red-tail Shark. Looking to add 4 Five Banded Barbs

Last edited by Barbman; 06-24-2011 at 05:47 PM.
Barbman is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
New koi acting weird. Ulyaoth Ponds and Waterfalls 4 08-14-2010 12:55 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome