Powerhead question... - Tropical Fish Keeping - Aquarium fish care and resources
LinkBack Thread Tools
post #1 of 4 Old 08-07-2008, 09:17 PM Thread Starter
New Member
Powerhead question...

I got a powerhead for my new saltwater tank and when I put it in it was working fine then after a few minutes it wasnt making any current. Anyone else had this problem? I hope its not that the powerhead broke...
Thanks in advance for the help.[/img]
closeyetfar is offline  
Sponsored Links
post #2 of 4 Old 08-07-2008, 09:28 PM
Pasfur's Avatar
Probably just the impeller. Wipe the impeller down and try again. Not unusual. (Remember the impeller getting stuck in Finding Nemo? Yeah, that thing.)
Pasfur is offline  
post #3 of 4 Old 08-07-2008, 09:33 PM Thread Starter
New Member
thanks..could it have anything to do with adding salt and sand to the tank today?

I checked the impeller but its still not pushing anything out. yet when i touch the sides of the powerhead i can feel the vibrations but no current from the powerhead
closeyetfar is offline  
post #4 of 4 Old 08-07-2008, 09:55 PM Thread Starter
New Member

haha i got it working thanks for the help
closeyetfar is offline  

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Forum Replies Last Post
Quick Powerhead question saulat Freshwater Aquarium Equipment 4 08-17-2009 07:01 AM
Accela powerhead question jstenzel Saltwater Aquarium Equipment 0 04-05-2009 03:45 PM
Hello & already have a question (powerhead) coyle Introduce Yourself 4 02-22-2009 03:02 PM
Powerhead help mikedelo Saltwater Aquarium Equipment 3 01-28-2009 04:00 AM
Powerhead question? Steenbergen Freshwater Aquarium Equipment 2 05-01-2007 08:50 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome