Tropical Fish Keeping - Aquarium fish care and resources

Tropical Fish Keeping - Aquarium fish care and resources (http://www.tropicalfishkeeping.com/)
-   Freshwater Aquarium Equipment (http://www.tropicalfishkeeping.com/freshwater-aquarium-equipment/)
-   -   eheim filter not turning on when plugged in (http://www.tropicalfishkeeping.com/freshwater-aquarium-equipment/eheim-filter-not-turning-when-plugged-98017/)

excal88 04-05-2012 10:52 PM

eheim filter not turning on when plugged in
 
Hey guys, so I just moved my eheim classic 2017 from my downstairs tank to my upstairs tank, and I just finished hooking it up and when I plugged it in, the motor is not turning on. It was working just fine when I unplugged it from my downstairs tank. There is already water in the canister as I used quick disconnnects. All my valves are open as well. I did notice that the 2 prongs on the plug are slightly rusted. Would that have anything to do with it not working? Or is the eheim completely dead? Thanks in advance.

Boredomb 04-05-2012 11:30 PM

If the plugs are not making contact it won't work but since it was just working I wouldn't think that would matter. This might sound stupid bur did you prime the pump? I know you said the canister was full cause you have quick connect but when you hooked the hoses back up and turned the quick connects was the inlet hose full of water before you turn the quick connects?

excal88 04-06-2012 12:11 AM

Yea, both hoses are full with water. When I plug in the filter, usually there's a gurgling sound or the such, but now there isn't and it stays silent. I have a feeling that the plug is old since the prongs are corroded, so my dad and I will probably take a look and attempt to replace it with a new one.

Boredomb 04-06-2012 01:05 AM

Ok well those are pretty easy to change out.

excal88 04-06-2012 04:13 AM

Ok so it turns out all I needed was quite a bit of elbow grease. I cleaned off the corrosion *wiped/scraped off the rust* took apart the impeller, cleaned it all out, wiped it down, and bam it started working. Thanks for the advice, I really appreciate it! Now only if I could get that aquarium water taste out of my mouth.....

AbbeysDad 04-06-2012 07:09 AM

Quote:

Originally Posted by excal88 (Post 1037161)
Now only if I could get that aquarium water taste out of my mouth.....

Industrial strength Listerine!!!


All times are GMT -5. The time now is 06:34 AM.

Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0 PL2