Tropical Fish Keeping - Aquarium fish care and resources

Tropical Fish Keeping - Aquarium fish care and resources (http://www.tropicalfishkeeping.com/)
-   Beginner Freshwater Aquarium (http://www.tropicalfishkeeping.com/beginner-freshwater-aquarium/)
-   -   Can someone please help me with Bio Cube (http://www.tropicalfishkeeping.com/beginner-freshwater-aquarium/can-someone-please-help-me-bio-72929/)

FlashGuppy 06-17-2011 01:40 PM

Can someone please help me with Bio Cube
 
I've had my 14 G Bio Cube for almost 2 years. I have it set up as a freshwater tank. A couple of months ago I purchased the BC stand for it and ever since I've had millions of micro bubble coming out of the main output. You cannot see anything inside the tank because it's so full of micro bubbles. The stand I had it on was not level and to balance it I had a piece of wood under neath the legs and it balanced it back a bit. Seems like since getting the stand it leveled it out and have not been able to get rid of the micro bubbles. I'm not a DIY kind of person and I've read online where many people have done things to upgrade this and that but I'm not DIY savvy and am afraid to change anything and really not have it work right. I've also been having a bacterial bloom issue that I'm waiting out.

I hope it's ok to post a diagram that I found that shows how the water input goes into the tank. This filtration system sits behind the tank itself. I've tried setting some floss media onto the drip tray on top of the bio balls without any luck. If I fill water to manufacturer's suggested level line, water trickling sounds like a loud toilet running. lol..really it does! If I fill water over the suggested line, it stops the bubbles and the noise, but I'm wondering if that is the cause somehow on why I now have that bloom I can't get rid of? Like maybe water has backed up or was not filtering right because I didn't follow manufacturer's suggestion. Altho the ideas I have read online have mentioned filling over suggested water line.

I am so confused with this set up. Never in my many years of having aquariums have I had the problems I've had with the Bio Cube. Also can anyone suggest a pump small enough to fit in the back of the wet dry compartment where I could possibly replace the stock pump and put one in where I could manage the flow of the water....it's very strong and my fish seem to get pushed around in the current.

Side note...right now I don't have any fish in it. I've moved them to my 20 gallon Marineland. So it's working with just live plants. Any suggestions and help will be greatly appreciated.

Here is the diagram of the filtration system.
http://i243.photobucket.com/albums/f...ube_filter.jpg

Byron 06-18-2011 12:13 PM

I have no personal experience with this unit so i won't guess at solutions. It would seem that air is getting in somehow, I know my canister filters do this but only for a few hours after cleaning/rinsing them.

As another option, since you are considering a different pump, can you remove this filter completely? I would suggest if you can, a simple sponge filter with a small air pump. That provides excellent filtration and minimal water movement. I use sponge filters on all my under-50 gallon tanks.

Byron.

FlashGuppy 06-19-2011 08:18 AM

Thanks for your post and reply to my thread Byron. I can definitely look into a sponge filter and see if I can use it in the back filter area. After I read your post last night I went and checked out the sponge filters online as I was not exactly sure what they were. I'm going to trouble shoot it today and see where there could be air getting in. All the fittings were tight last night so I'm thinking could be the sponge that is in the wet/dry sump area....may be too pourous ...that is the stock sponge it came with.

In looking at your profile that you have your tanks photos, I only saw one under 50 gallons? Where do you have the sponge filter in it? If it's hidden behind all the plants thats pretty cool...you can't even see it.

Byron 06-19-2011 12:52 PM

1 Attachment(s)
Quote:

Originally Posted by FlashGuppy (Post 705258)
Thanks for your post and reply to my thread Byron. I can definitely look into a sponge filter and see if I can use it in the back filter area. After I read your post last night I went and checked out the sponge filters online as I was not exactly sure what they were. I'm going to trouble shoot it today and see where there could be air getting in. All the fittings were tight last night so I'm thinking could be the sponge that is in the wet/dry sump area....may be too pourous ...that is the stock sponge it came with.

In looking at your profile that you have your tanks photos, I only saw one under 50 gallons? Where do you have the sponge filter in it? If it's hidden behind all the plants thats pretty cool...you can't even see it.

I have a 10g, 20g, 29g and 33g tank, each has a sponge filter. The 10g has a Hydor, the 20g and 29g have a dual Elite (pictured below, this is my personal favourite), and the 33g has a little Eheim sponge with its own motor [avoids an air pump, the other two types use an air pump] but I understand they don't make these anymore. The Elite also comes in a single-sponge model.

Byron.


All times are GMT -5. The time now is 10:05 PM.

Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0 PL2