Tropical Fish Keeping - Aquarium fish care and resources

Tropical Fish Keeping - Aquarium fish care and resources (http://www.tropicalfishkeeping.com/)
-   Beginner Freshwater Aquarium (http://www.tropicalfishkeeping.com/beginner-freshwater-aquarium/)
-   -   Eheim 2217 pressure problem (http://www.tropicalfishkeeping.com/beginner-freshwater-aquarium/eheim-2217-pressure-problem-32479/)

JerseyBird97 11-18-2009 12:39 PM

Eheim 2217 pressure problem
 
I do not think my filter has the output pressure it should. Any suggestions?

Byron 11-18-2009 01:24 PM

When filter flow decreases, the first thing to do is clean it by rinsing the pads and media. At the same time, check that the water path is as it should be, not being blocked by media. Start it up and see.

I am not sure of the exact model, but some Eheims have a flow regulator, it might have been reduced without knowing.

Also, age may impact it, though Eheims are well made filters.

If the above doesn't resolve the flow, let us know; I'm sure someone here has experience with this model. My Eheims are more than 12 years old, and still running without a hitch.

Byron.

JerseyBird97 11-18-2009 01:29 PM

If it does have a flow regulator where would it be located?

Byron 11-18-2009 02:58 PM

Quote:

Originally Posted by JerseyBird97 (Post 276365)
If it does have a flow regulator where would it be located?

Not sure, my Eheims are old enough not to have them, the newer models do. My Rena XP3 has one that I attached at the outflow tube just before the spray bar. I think Twistersmom has Eheims, she may know; PM her if she doesn't chime in.

B.

JerseyBird97 11-18-2009 03:21 PM

Ok just emptied out the canister rinsed all the media and pads put it all back together and it seems to running even slower the output is a mear trickle

WisFish 11-18-2009 03:28 PM

I have this model. It doesn't have a flow-control per-see but it does have shut-off values that should be all the way open.

Other things to consider that affect flow. Are you reusing pads or replacing them? Did you clean out the impeller assembly? Are the green tubes goijng to/from the canister clogged with green/brown stuff? Any snails or gravel stuck in the input tubes? Is the input screen clogged? When the impeller is cleaned, did you lube it up with vasoline?

JerseyBird97 11-18-2009 03:31 PM

I'll go through that check list and let ya know how it turned out

JerseyBird97 11-18-2009 03:59 PM

Cleaned ou the impellor... now it's running good!

Angel079 11-18-2009 07:00 PM

That's the only 'downside' really on Eheims over a long term, unless you REALLY make sure to clean the impellor & housing there about once a year it can slow your filter WAY down, just add it to your regular maintenance list and you'll be set.

Twistersmom 11-18-2009 08:26 PM

Just noticed your post now. I also have the Eheim 2217, great filter. Glad you got it fixed!


All times are GMT -5. The time now is 01:58 AM.

Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0 PL2