Tropical Fish Keeping - Aquarium fish care and resources

Tropical Fish Keeping - Aquarium fish care and resources (http://www.tropicalfishkeeping.com/)
-   Freshwater Aquarium Equipment (http://www.tropicalfishkeeping.com/freshwater-aquarium-equipment/)
-   -   Filter stopped working (http://www.tropicalfishkeeping.com/freshwater-aquarium-equipment/filter-stopped-working-27596/)

fishyinpa 08-20-2009 04:03 PM

Filter stopped working
 
So I was sitting here earlier and noticed that there was no current in my Pandas tank. Its a 12 gallon Eclipse system,with that biowheel set up. I did a wc on them anyways,so I took off the filter part. Took it apart,took out the impeller (looked fine,nothing stuck on it). Nothing was lodged anywhere. So I dont know why its not doing anything. I called Marineland,and he had me turn it over,with impeller in,to see if it turned. Well it did,so he said filter is fine. I was like um but its not,its not doing anything. So I have no idea what else to do. The lfs is a pain,they told me to call Marineland cause they dont do exchanges. Help??

eileen 08-20-2009 04:19 PM

I have 3 Eclipses. The MarineLand is expensive if you have to get parts. I looked on-line and found replacement parts at 1/2 the price over MarineLand. I have to tell you that I heard that MarineLand is doing away with the Eclipse tanks. I have a friend and she told me that she looks for replacement peices on Craigslist in case something breaks.My propeller on the bio wheel does not turn sometimes. I have to check it offen. I have a netting over my intake so my dwarf shrimps and baby fry do not get sucked in. I have to clean the netting and then the bio wheel works fine. clean out the magnetic propeller to the filter sometimes it just needs cleaning in and around the casing that it sits on. If the tank is new they are covered by the company for a short period of time. I really don't know what you can do without a filter if you do send it back for another one. Eclipse tanks are difficult as the filter sits on top. You can not put a temp. filter in the back as it will not fit. You could get one that sits inside the tank til you get the one replaced. With no filter you will have to do plenty of water changes til the new filter comes.

fishyinpa 08-20-2009 04:23 PM

Oh,great. Thats just,wonderful lol. Only thing I can think of is maybe sand is stuck on the impeller somehow? Other than that,I see nothing else wrong with it. Guess Ill take the filter off again and maybe soak the impeller for awhile. I do have a submersible filter I was using in the old tank if I have to I will use that,but the one that came with the tank was so nice! I havent had it long at all,maybe a month. Is this common to just stop working one day and so soon? Thanks Eileen.

eileen 08-20-2009 04:31 PM

I got my Eclipse because a friend likes them. If I had known I would not have got it. The other eclipse tanks I have came from craigslist by accident. My 5 gal. was free alittle scratched up but fine and the Hex 5 gal. was only $10 on craigslist and replaced a 2.5 gal. Hospital tank. Clean the filter out really good where the magnetic propeller is. If you have a small brush to clean it or use a Q-TIP. Mine stoped working and I messed with it and cleaned it and then it worked again. I have not had a problem after that. I'm not sure what area is not working for you. Is it the Bio-wheel or the magnetic propeller thing?

fishyinpa 08-20-2009 04:40 PM

Oh okay. Well I took it off again. Checked everything. I got a flashlight and could see the impeller blades moving. So it dawned on me,maybe try putting it in just like that,no intake tube. Eureka,now it works. I put the intake tube back from inside the tank,now its good. A mystery as to why it stopped in the first place,but hopefully it keeps working. Else I will be looking into some other kinda filter. Thanks for everything.

eileen 08-20-2009 05:13 PM

I'm glad that it works now. I had the same problem with mine. I had to giggle the intake thing after setting it back on top of the holder from inside the tanks water and it started working. Next time it acts up on you that is what you have to do. Also make sure the parts are cleaned every now and then from muck.

fishyinpa 08-20-2009 05:29 PM

Yes I am glad too. What a pain though. :)


All times are GMT -5. The time now is 01:39 AM.

Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0 PL2