Tropical Fish Keeping - Aquarium fish care and resources

Tropical Fish Keeping - Aquarium fish care and resources (http://www.tropicalfishkeeping.com/)
-   Tropical Fish Diseases (http://www.tropicalfishkeeping.com/tropical-fish-diseases/)
-   -   Problems with Eclipse 1 (http://www.tropicalfishkeeping.com/tropical-fish-diseases/problems-eclipse-1-a-16522/)

Max77 07-25-2008 10:24 AM

Problems with Eclipse 1
 
I am cycling a 10 gallon tank with a Eclipse 1 system 12. My family has had this tank since 98. We have replaced the light once but we have never replaced anything else.The power went out one night in a storm and the filter had to restart. It made clicking noises until it restarted. Then it started flowing out of the back of the tank. It seems as if the intake for the filter is pumping way to much water for the littler well to hold. Whenever i open the light hood thing to feed them it overflows. I think the filter is just dieing. If any one has ever had any thing like this happen, do you have any advice?

aquakid 07-25-2008 12:56 PM

One Thing Is You should make sure you filter pump is in the right place
then you should change your filter media
also the clicking noise is just the filter priming since it is self priming

okiemavis 07-25-2008 04:05 PM

I'd take it apart and clean out all the parts. It sounds like something may be clogged which isn't allowing water to flow back out at the rate it's supposed to. Hopefully when it restarted it just knocked something out of place or sucked up something which is now causing a clog.

If that fails, well, I guess it depends how in-depth you want to get, you could probably find a diagram of all the parts online and go through and figure out if any of them are broken.

Max77 07-25-2008 05:50 PM

Thanks for your reply. I went ahead and got a new filter and a lighting hood. I got a Whisper 20i in tank filter. Is this a good filter


All times are GMT -5. The time now is 07:25 AM.

Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0 PL2