They're All Dead. why? - Tropical Fish Keeping - Aquarium fish care and resources
 
LinkBack Thread Tools
post #1 of 7 Old 02-04-2011, 12:25 PM Thread Starter
They're All Dead. why?

I had 4 baby fish. yesterday i gave all my tanks frozen bloodworms, and now they all died, + my balloon molly. Was it the bloodworms? all my fish ate them, but only those 5 fell ill/died. Was it the bloodworms? Could they have been rotten? The exp. date was in 2013, so i figured they were alright.
coolcucumber is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 02-04-2011, 12:30 PM
Member
 
stevenjohn21's Avatar
 
i had the same problem last year, my freezer was working on and off so everything in the freezer froze and defrosted every now and again making the bloodworms go off.

It killed all my fry
stevenjohn21 is offline  
post #3 of 7 Old 02-04-2011, 12:32 PM Thread Starter
Oh. So i can blame it on the worms. ill toss em, then, and buy new ones.
coolcucumber is offline  
post #4 of 7 Old 02-05-2011, 11:02 AM
New Member
 
fan4guppy's Avatar
 
Quote:
Originally Posted by stevenjohn21 View Post
i had the same problem last year, my freezer was working on and off so everything in the freezer froze and defrosted every now and again making the bloodworms go off.

It killed all my fry
Quote:
Originally Posted by coolcucumber View Post
Oh. So i can blame it on the worms. ill toss em, then, and buy new ones.
I would not be so hasty in thinking that it was your blood worms as the date on them was not passed.

There may be other reasons for the loss of your fry. Water Parameters, Filter issues, etc. can all be involved.

If you fed your other fish and they are still alive I highly doubt that it was the food that you were feeding to your fish.
fan4guppy is offline  
post #5 of 7 Old 02-05-2011, 11:43 AM Thread Starter
I also lost 2 other fish :)
coolcucumber is offline  
post #6 of 7 Old 02-05-2011, 12:27 PM
New Member
 
fan4guppy's Avatar
 
Did you loose all your fish in your tank?

Have you checked nitrites, ammonia levels etc?

If your freezer was not working then I can see more of the possibility of it being the blood worms.
fan4guppy is offline  
post #7 of 7 Old 02-05-2011, 12:32 PM Thread Starter
I think the frezzer stopped for a while, and it was them. all the water params were fine, they were fine before i fed them
coolcucumber is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Is it dead? Blaxicanlatino Invertebrates 11 12-03-2008 07:35 PM
dead sps dallops_of_polyps Saltwater Fish Diseases 2 03-04-2008 12:06 PM
no 3/4 dead spy1011 Tropical Fish Diseases 8 08-27-2007 04:46 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome