Help!!! Found all my guppies dead!?!
Tropical Fish

Tropical Fish Keeping - Aquarium fish care and resources » Freshwater Fish and Aquariums » Freshwater and Tropical Fish » Livebearers » Help!!! Found all my guppies dead!?!

Help!!! Found all my guppies dead!?!

This is a discussion on Help!!! Found all my guppies dead!?! within the Livebearers forums, part of the Freshwater and Tropical Fish category; --> I just recently got 4 male guppies, and had only had them for 2 days. I noticed that the guppies had some red spots ...

Check out these freshwater fish profiles
Platy
Platy
Platy
Platy
Reply
LinkBack Thread Tools vBmenu Seperating Image Search this Thread vBmenu Seperating Image
Help!!! Found all my guppies dead!?!
Old 01-25-2013, 02:52 AM   #1
 
Unhappy Help!!! Found all my guppies dead!?!

I just recently got 4 male guppies, and had only had them for 2 days. I noticed that the guppies had some red spots (like oval shape) or some stripes on their body. I thought it was just their pattern because it was identical on both sides of the guppy. I also noticed they seemed to be flicking themselves or darting around sometimes and rubbing on the walls, but I thought maybe they were stressed... But I checked on them (as I was doing every few hours) before I went out and they were fine and when I came back (3hrs) all four of them were dead!!!
I have no idea what happened, it was a hot day 82 degrees Fahrenheit (28 degrees Celsius)

Please help me find out what went wrong!
Katymac101 is offline   Reply With Quote
Old 01-25-2013, 08:34 AM   #2
 
Sound like an infection because if they had oval red spots and dart around, this is possible. Have guppies and they dart also, but it looks like they are trying to scratch themselves. Sorry about your deaths
Kuddos 2 U is offline   Reply With Quote
Old 01-25-2013, 04:30 PM   #3
 
U think so? The spots werenthere when we got them but they were matching on both sides of the fish. They were flipping their tummies up at the sky some times like they were trying to flick something off but they stopped and then they all died :( thanks for replying :)
Katymac101 is offline   Reply With Quote
Old 01-25-2013, 06:59 PM   #4
 
Romad's Avatar
 
It could be a number of reasons. Did you cycle a tank before adding them? What size tank were they in? Do you have any idea of what the PH was and did you condition the tank water before you added the fish?
Romad is offline   Reply With Quote
Old 01-25-2013, 11:02 PM   #5
 
Knowing a bit more about your situation would be helpful - was this a new tank or just new fish being added to an existing tank? If it's the latter, are there other fish in the tank and, if so, have you noticed any changes in the condition of the other fish? If it's the former, how long has the tank been active, what process of cycling the tank did you follow, what size is the tank, etc?
ETA - I am sorry for your loss.
ZivaD is offline   Reply With Quote
Old 01-26-2013, 12:07 AM   #6
 
It's a new tank these were the only fish in it, I don't know what the Ph and stuff was but it was set up for 5 days and we put a conditioner and bio filter liquid in the water first because that's what the fish store told us to do, then they said 5 days is good and so we put the fish in. It it about a meter and a half across and a meter deep.
Katymac101 is offline   Reply With Quote
Old 01-26-2013, 08:21 AM   #7
 
Quote:
Originally Posted by Katymac101 View Post
It's a new tank these were the only fish in it, I don't know what the Ph and stuff was but it was set up for 5 days and we put a conditioner and bio filter liquid in the water first because that's what the fish store told us to do, then they said 5 days is good and so we put the fish in. It it about a meter and a half across and a meter deep.
Did the fish store staff talk about water testing kits or show/sell you anything to test your water parameters with? The fish were in the tank for about two days, correct? After you added the fish did you do any maintenance to the tank in those two days?
ZivaD is offline   Reply With Quote
Old 01-26-2013, 10:21 PM   #8
 
Quote:
Originally Posted by ZivaD View Post
Did the fish store staff talk about water testing kits or show/sell you anything to test your water parameters with? The fish were in the tank for about two days, correct? After you added the fish did you do any maintenance to the tank in those two days?
No they didn't, I didn't do anything to the tank, I would just sit and watch them swimming around.
Katymac101 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
found my nemo dead........ 92smokeaccord Beginner Saltwater Aquariums 1 08-18-2012 10:30 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -5. The time now is 10:42 AM.