What is wrong with my tank?! - Tropical Fish Keeping - Aquarium fish care and resources
 
LinkBack Thread Tools
post #1 of 4 Old 12-05-2013, 02:44 PM Thread Starter
New Member
 
SophiebethK's Avatar
 
What is wrong with my tank?!

Hi everyone, i have had fish in my tank for a wee while now but still pretty new to it all. I currently have 4 platy's a male siamese fighter and snails,which are the main cause for my post 2 days ago i had 5, i now have 2
I dont know what happened, my tank was clean, i do frequent 25-50% changes, i ahve lots of live plants and we where all happy. Then when i went to check on them the other day two of my snails (one tiger and one spotted) where lying upside down, as if they had lost grip of the glass. I picked them up and sorted them asap but unfortunately they left for snail heaven. Then when i woke up the next morning another one was upiside down and quickly followed the other two to snail heaven. I now only have two left which seem fine but seem to prefer being above the water level?
I did a water change to make sure there was no extra ammoniaor anything with having dead snails.
Does anyone have any idea what the cause for this could be? I dont want to lose my last two remaining snails.
SophiebethK is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 12-05-2013, 03:12 PM
Quote:
Originally Posted by SophiebethK View Post
Hi everyone, i have had fish in my tank for a wee while now but still pretty new to it all. I currently have 4 platy's a male siamese fighter and snails,which are the main cause for my post 2 days ago i had 5, i now have 2
I dont know what happened, my tank was clean, i do frequent 25-50% changes, i ahve lots of live plants and we where all happy. Then when i went to check on them the other day two of my snails (one tiger and one spotted) where lying upside down, as if they had lost grip of the glass. I picked them up and sorted them asap but unfortunately they left for snail heaven. Then when i woke up the next morning another one was upiside down and quickly followed the other two to snail heaven. I now only have two left which seem fine but seem to prefer being above the water level?
I did a water change to make sure there was no extra ammoniaor anything with having dead snails.
Does anyone have any idea what the cause for this could be? I dont want to lose my last two remaining snails.
Do u know what ur water hardness is? I have a terrible time keeping snails because my water is so soft. Not enough calcium to support then. Also, if the tank is new they may have been not getting enough to eat. Ive been through about 10 apple snails before i just gave up and realized maybe im just not suited for snails. This is speculation but something to look in to :)

4 gallon betta tank
75 gallon FW community
20 gallon SAP tank
10 gallon snails
NewFishFiend is offline  
post #3 of 4 Old 12-05-2013, 03:20 PM Thread Starter
New Member
 
SophiebethK's Avatar
 
Water hardness? Fish store man never mentioned that. Ah, we have soft water here. How would I harden it or get more calcium into it?
SophiebethK is offline  
post #4 of 4 Old 12-05-2013, 04:36 PM
Member
 
Ogre44's Avatar
 
If they prefer to be out of the water one of your parameters is most likely off.
I don't know what constitutes a "wee while" but are you sure your tank is fully cycled?
Do you know, or can you test, what your values for Ammonia, Nitrite, and Nitrate are?
What about your PH?
Ogre44 is offline  
Reply

Tags
nerite , nerite snails , sickness , snails

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
My whole tank seems to have gone wrong Ogre44 Beginner Freshwater Aquarium 26 12-20-2011 04:32 PM
I don't know what is wrong with my tank... mastermusician1 Tropical Fish Diseases 8 01-24-2009 02:22 AM
New Tank -- Bully, or something else wrong? Ludo Tropical Fish Diseases 3 05-26-2007 04:40 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome