sick ghost catfish - Tropical Fish Keeping - Aquarium fish care and resources
LinkBack Thread Tools
post #1 of 3 Old 11-05-2011, 10:57 AM Thread Starter
New Member
Unhappy sick ghost catfish

hello everyone, i have two ghost catfish in a 10g tank with two tetras and a bristlenose pleco. the ghost cats seem to be very sick. most of the time they are laying on the gravel looking dead but then they get up and swim a little. one of them sometimes swims upside-down. i thought i saw what might be some type of fin rot on one so i treated the tank with anti-bacterial medicine but it did not seem to work. any insight to this issue would be appreciated. thanks
mileshs95 is offline  
Sponsored Links
post #2 of 3 Old 11-05-2011, 07:10 PM
How long has your tank been set up? It could be a water quality issue or a stress issue. Ghost catfish like to be in groups of atleast 6 minimum but the more the better. Same with tetras too atleast 5-6.
SomeDudeAtHome is offline  
post #3 of 3 Old 11-05-2011, 09:39 PM Thread Starter
New Member
the tank has been up since early september, and it seems that one of the catfish is missing the bottom part of his tail-fin. also he is not using his left fin at all which is causing him to swim sideways
mileshs95 is offline  

catfish , fin rot , ghost catfish , glass catfish , sick

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ghost catfish? surfnchk Catfish 3 09-17-2010 05:19 PM
Angelfish and Ghost Catfish The Noob Fish Shepherd Freshwater and Tropical Fish 3 03-16-2010 05:55 AM
ghost catfish possible breeding???? xxchickyxx89 Catfish 3 03-04-2010 05:35 AM
Ghost Catfish HELP Jessica Catfish 4 11-05-2008 10:11 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome