filter not doing anything - Tropical Fish Keeping - Aquarium fish care and resources
 
LinkBack Thread Tools
post #1 of 4 Old 08-20-2009, 05:14 PM Thread Starter
Member
 
fishyinpa's Avatar
 
filter not doing anything

So I posted in equipment but figured I would try here too. I have a Marineland Eclipse 12 system for my corys. The filter has been working fine all this time. Now it just stopped working. I took it apart,nothing wrapped around the impeller. When I put it back in and plug it in,you can feel it doing something,but its not intaking any water or sending any out. I dont know what to do. There is sand substrate,could that be the problem? Please help. Thanks.

3 gallon male betta
10 gallon male betta
12 gallon QT
30 gallon
1 Pl*co, Brochis Splenden,False Julii Cory,Pygmy Corys,Female Betta,Harlequin Rasbora,Tetras
55 gallon Possible Barb tank?!



Swim free

All my past fishies


fishyinpa is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 08-20-2009, 05:37 PM Thread Starter
Member
 
fishyinpa's Avatar
 
NM. I got it working. LOL

3 gallon male betta
10 gallon male betta
12 gallon QT
30 gallon
1 Pl*co, Brochis Splenden,False Julii Cory,Pygmy Corys,Female Betta,Harlequin Rasbora,Tetras
55 gallon Possible Barb tank?!



Swim free

All my past fishies


fishyinpa is offline  
post #3 of 4 Old 08-21-2009, 12:57 PM
Gold Member
 
aunt kymmie's Avatar
 
Excellent news!

If you don't stand up for something you'll fall for anything...
aunt kymmie is offline  
post #4 of 4 Old 08-22-2009, 06:27 PM
Glad to hear everything is ok now! lol
dramaqueen is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ugh! Tank of Troubles - old filter quit - new filter not seeded PaperclipGirl Beginner Freshwater Aquarium 16 03-11-2010 04:24 AM
eclipse filter, 20gal carbon filter dirties quickly gregm61881 Beginner Freshwater Aquarium 4 10-06-2008 09:14 AM
Alternative filter media for power filter okiemavis Freshwater Aquarium Equipment 1 04-05-2008 02:57 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome