Aquaclear 30 help? - Tropical Fish Keeping - Aquarium fish care and resources
 
LinkBack Thread Tools
post #1 of 3 Old 10-06-2010, 06:58 AM Thread Starter
Aquaclear 30 help?

Flow rate is slow. With and without filter media on maximum flow rate. Cleaned the filter media. Still slow. Unhooked and cleaned the motor/impeller and added some 'ycle' to grease it up and still slow. It trickles, I have only had it for about 5 weeks now and at the beginning the flow was a lot stronger.

Has anyone ever had this problem or similar? Any ideas?

I'm in Australia and there is no warranty phone number on the box :s Anyone know who to contact for the warranty?


Thanks a lot, my fish need a filter!
dudewheresmyfish is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 10-06-2010, 08:07 AM
Member
 
bearwithfish's Avatar
 
you could look up AC on line and see if they can help from there.. it sounds like you just got a faulty one because you already did everything i would suggest and there really isn't more you can do with out buying parts and or a new filter....

Back in the Game!!! Live Bearers in a 40 Breeder
bearwithfish is offline  
post #3 of 3 Old 10-06-2010, 01:43 PM
Member
 
Calmwaters's Avatar
 
I agree with Bear.

Kindest Regards,
Amanda

Keeping fish its not a hobby it is a passion!

55 gallon, 44 gallon, one 20 gallon tank, three 10 gallon tanks, and a 2.5 gallon all with real plants.

I have MTS and there is no cure.

Calmwaters is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Aquaclear 50 aaronjunited Freshwater Aquarium Equipment 3 04-19-2010 01:08 AM
Aquaclear filtration question LisaC144 Beginner Freshwater Aquarium 9 11-27-2009 09:04 AM
Looking for someone with an AquaClear 20 (question on certain dimensions) gus6464 Freshwater Aquarium Equipment 0 09-22-2009 10:41 PM
AquaClear Foam Insert? MrWynO14 Freshwater Aquarium Equipment 4 09-04-2009 01:12 PM
Aquaclear vs. Emperor fishluver06 Freshwater Aquarium Equipment 7 04-19-2008 03:42 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome