Why is impeller rattling - Tropical Fish Keeping - Aquarium fish care and resources
 
LinkBack Thread Tools
post #1 of 9 Old 04-07-2012, 11:35 AM Thread Starter
New Member
 
Why is impeller rattling

Every time I do water change and turn off filter (eclipse w/bio filter), then turn back on it rattles...filter will stop running. Then sputter and rattle back to life. I turn it on and off to get it going. Even after it's running it'll continue to rattle intermittently. I've made sure there is nothing obstructing the inflow. Is it time to replace?
cmarshall is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 04-07-2012, 01:08 PM
zof
Member
 
zof's Avatar
 
You're in the wrong area of the forum, you will get a better response if you post this up in the equipment section.
zof is offline  
post #3 of 9 Old 04-07-2012, 02:57 PM
TFK Moderator
 
Romad's Avatar
 
Thread moved for you.

Have you tried cleaning the impeller itself? They can get pretty gunky after a while. I have to clean all of mine every few months or so.

Animal testing is a terrible idea; they get all nervous and give the wrong answers.
Romad is offline  
post #4 of 9 Old 04-09-2012, 03:12 PM
New Member
 
Didn't somebody mention that some Marineland filters had the magnets installed wrong and it caused the impeller to rattle?
TwinDad is offline  
post #5 of 9 Old 04-10-2012, 01:53 AM
Member
 
lorax84's Avatar
 
With any filter, if the impeller is dirty you may have problems with it starting spinning again after being unplugged. Just take out the impeller and clean it, it should spin freely when you put it back in.
lorax84 is offline  
post #6 of 9 Old 04-10-2012, 04:06 PM
Member
 
the one in my kids tank was doing this forever. i took it out and it was completly seized up. i took the shaft out and freed everything up. the shaft was worn to the point that there were grooves in it. i believe this was the original one and is well over ten years old. i had a new one onhand so i just tossed it it. i kept the old one just incase the new one craps out for any reason.

46g bowfront freshwater
10g freshwater
skelator is offline  
post #7 of 9 Old 04-10-2012, 07:01 PM
Member
 
fish monger's Avatar
 
If your filter is a hang on the back with the motor outside of the water, clean as others have said and make sure the filter is filled most of the way with water. Other than that, I guess it could need to be replaced.
fish monger is offline  
post #8 of 9 Old 04-12-2012, 12:43 PM
Member
 
my new impeller kept stopping for some reason. so i threw the ten year old one back in. shes a little nosiy but its runnnin fine.

46g bowfront freshwater
10g freshwater
skelator is offline  
post #9 of 9 Old 05-07-2012, 11:14 PM
New Member
 
Smile rattling filter

am new but read a lot. looks like everyone knows you clean impellers. I just started out with an aquarium but have read a lot on the Internet to be dangerous! Will be getting 2 guppies to start out next week while my little 10-gallon tank chugs away to start cycling.
tommy ivers is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Water Pump Impeller Problems reel Beginner Freshwater Aquarium 0 11-02-2010 10:18 AM
Rio 600 impeller question Pasfur Saltwater Aquarium Equipment 1 03-24-2009 10:34 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome