Why is impeller rattling
Tropical Fish

Tropical Fish Keeping - Aquarium fish care and resources » Freshwater Fish and Aquariums » Beginner Freshwater Aquarium » Freshwater Aquarium Equipment » Why is impeller rattling

Why is impeller rattling

This is a discussion on Why is impeller rattling within the Freshwater Aquarium Equipment forums, part of the Beginner Freshwater Aquarium category; --> Every time I do water change and turn off filter (eclipse w/bio filter), then turn back on it rattles...filter will stop running. Then sputter ...

Reply
LinkBack Thread Tools vBmenu Seperating Image Search this Thread vBmenu Seperating Image
Why is impeller rattling
Old 04-07-2012, 12:35 PM   #1
 
Why is impeller rattling

Every time I do water change and turn off filter (eclipse w/bio filter), then turn back on it rattles...filter will stop running. Then sputter and rattle back to life. I turn it on and off to get it going. Even after it's running it'll continue to rattle intermittently. I've made sure there is nothing obstructing the inflow. Is it time to replace?
cmarshall is offline   Reply With Quote
Old 04-07-2012, 02:08 PM   #2
zof
 
zof's Avatar
 
You're in the wrong area of the forum, you will get a better response if you post this up in the equipment section.
zof is offline   Reply With Quote
Old 04-07-2012, 03:57 PM   #3
 
Romad's Avatar
 
Thread moved for you.

Have you tried cleaning the impeller itself? They can get pretty gunky after a while. I have to clean all of mine every few months or so.
Romad is offline   Reply With Quote
Old 04-09-2012, 04:12 PM   #4
 
Didn't somebody mention that some Marineland filters had the magnets installed wrong and it caused the impeller to rattle?
TwinDad is offline   Reply With Quote
Old 04-10-2012, 02:53 AM   #5
 
lorax84's Avatar
 
With any filter, if the impeller is dirty you may have problems with it starting spinning again after being unplugged. Just take out the impeller and clean it, it should spin freely when you put it back in.
lorax84 is offline   Reply With Quote
Old 04-10-2012, 05:06 PM   #6
 
the one in my kids tank was doing this forever. i took it out and it was completly seized up. i took the shaft out and freed everything up. the shaft was worn to the point that there were grooves in it. i believe this was the original one and is well over ten years old. i had a new one onhand so i just tossed it it. i kept the old one just incase the new one craps out for any reason.
skelator is offline   Reply With Quote
Old 04-10-2012, 08:01 PM   #7
 
fish monger's Avatar
 
If your filter is a hang on the back with the motor outside of the water, clean as others have said and make sure the filter is filled most of the way with water. Other than that, I guess it could need to be replaced.
fish monger is offline   Reply With Quote
Old 04-12-2012, 01:43 PM   #8
 
my new impeller kept stopping for some reason. so i threw the ten year old one back in. shes a little nosiy but its runnnin fine.
skelator is offline   Reply With Quote
Old 05-08-2012, 12:14 AM   #9
 
Smile rattling filter

am new but read a lot. looks like everyone knows you clean impellers. I just started out with an aquarium but have read a lot on the Internet to be dangerous! Will be getting 2 guppies to start out next week while my little 10-gallon tank chugs away to start cycling.
tommy ivers is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Water Pump Impeller Problems reel Beginner Freshwater Aquarium 0 11-02-2010 11:18 AM
Rio 600 impeller question Pasfur Saltwater Aquarium Equipment 1 03-24-2009 11:34 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -5. The time now is 12:46 AM.