uv sterilizer - no water flow - Tropical Fish Keeping - Aquarium fish care and resources
LinkBack Thread Tools
post #1 of 2 Old 11-12-2008, 10:11 PM Thread Starter
New Member
uv sterilizer - no water flow

I just installed a Helix Max 9 watt UV sterilizer but cannot seem to get water flowing through the unit. Can anybody offer me some help.
zingbri is offline  
Sponsored Links
post #2 of 2 Old 11-13-2008, 08:33 AM
Tyyrlym's Avatar
According to the instruction manual I found on-line, http://www.swelluk.com/pdfs/Heli%20M...structions.pdf , this type of sterilizer doesn't have an internal pump. It's for setting up in line with a pump, either with a filter or by itself. It can't move water on its own.

Tetra Fanatic
Watch my tank progress from Craigslist salvage to fishy habitat: Aaron's Tank
The only things that happen quickly in an aquarium are bad things.
Tyyrlym is offline  

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Forum Replies Last Post
Difference between good water flow and splashing water flow? jkastner19 Beginner Freshwater Aquarium 3 08-27-2007 03:25 PM
Water flow dave12678 Saltwater Aquarium Equipment 8 05-07-2007 04:44 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome