Quick Powerhead question
Tropical Fish

Tropical Fish Keeping - Aquarium fish care and resources » Freshwater Fish and Aquariums » Beginner Freshwater Aquarium » Freshwater Aquarium Equipment » Quick Powerhead question

Quick Powerhead question

This is a discussion on Quick Powerhead question within the Freshwater Aquarium Equipment forums, part of the Beginner Freshwater Aquarium category; --> Just installed my first powerhead. It is a Regent Aqua Tech from walmart rated at 170 GPH. I bought it mainly to add some ...

Reply
LinkBack Thread Tools vBmenu Seperating Image Search this Thread vBmenu Seperating Image
Quick Powerhead question
Old 08-15-2009, 07:15 PM   #1
 
Quick Powerhead question

Just installed my first powerhead. It is a Regent Aqua Tech from walmart rated at 170 GPH. I bought it mainly to add some circulation for my pressurized Co2 that I just added. Currently I have the Co2 running into the venturi plug but not yet turned on as I am not ready for it, although it is tested and works. My question is I am getting a lot of bubbles coming from the powerhead even though the Co2 is turned off. Is this normal? I don't want O2 coming from the powerhead I really just want it for water circulation and maybe Co2. Putting the plug into the venturi plug keeps the bubbles from coming out but leaving it open in the water without the co2 tube and there is bubbles.

I did find some leaks in my homemade bubble counter but there are bubbles even without the co2 tube running into it.
saulat is offline   Reply With Quote
Old 08-16-2009, 01:38 AM   #2
 
MoneyMitch's Avatar
 
take off any air hose you have connected to your ph. it pulls in air through that tube and mixes it with the water for more aggitation. you have a co2 system why do you want more water agitation???
MoneyMitch is offline   Reply With Quote
Old 08-16-2009, 10:20 AM   #3
 
Well my Co2 system is brand new I was just testing it through the powerhead. I have the powerhead aimed away from the tank surface, just adding circulation to the tank. I just dont understand why there are bubble when the hole has no hose in it but if I use the plug that came with it they stop. The bubble also happen when the co2 is plugged in so I am guessing it is both oxygen and co2. I may run the co2 through the powerhead at a later date but for now will use my canister filter.
saulat is offline   Reply With Quote
Old 08-17-2009, 12:25 AM   #4
 
MoneyMitch's Avatar
 
there might be some type of leak somewhere letting in oxygen in and causing the bubbles check there.
MoneyMitch is offline   Reply With Quote
Old 08-17-2009, 08:01 AM   #5
 
Ill play with it some more when I get home. The only thing out of the water would be the powercord. Kinda wierd I guess Ill just leave the plug in tille future notice.
saulat is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Accela powerhead question jstenzel Saltwater Aquarium Equipment 0 04-05-2009 04:45 PM
Hello & already have a question (powerhead) coyle Introduce Yourself 4 02-22-2009 04:02 PM
A Quick Question meatball Beginner Freshwater Aquarium 7 02-02-2009 05:27 PM
Powerhead question... closeyetfar Saltwater Aquarium Equipment 3 08-07-2008 10:55 PM
Powerhead question? Steenbergen Freshwater Aquarium Equipment 2 05-01-2007 09:50 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -5. The time now is 08:10 PM.