filter question
Tropical Fish

Tropical Fish Keeping - Aquarium fish care and resources » Freshwater Fish and Aquariums » Beginner Freshwater Aquarium » Freshwater Aquarium Equipment » filter question

filter question

This is a discussion on filter question within the Freshwater Aquarium Equipment forums, part of the Beginner Freshwater Aquarium category; --> ok i have 2 Marineland Penguin 350 filters and 1 out of the 2 bio wheels barley ever spins, while the other one is ...

Reply
Old 09-11-2007, 09:52 PM   #1
 
filter question

ok i have 2 Marineland Penguin 350 filters and 1 out of the 2 bio wheels barley ever spins, while the other one is completely fine. but the weird thing is its happening to both of my filters so instead of all 4 spinning i only have 2 spinning on different filters. anyone know what could cause this?
cullens089 is offline   Reply With Quote
Old 09-11-2007, 10:14 PM   #2
 
fish_4_all's Avatar
 
The easiest thing to check is to spin them by hand, if the ones that don't spin well with the water don't spin freely then I would say it is a problem with the filter and I would take them back. If they do spin the same as the ones that work right then it is likely a matter of breaking in the filter and allowing the water to flow evenly over both outlets so that both biowheels get enough water for them to operate correctly. Do both of them have the same outflow across the biowheel? Maybe try switching them with each other if that is at all possible.
fish_4_all is offline   Reply With Quote
Old 09-11-2007, 10:25 PM   #3
 
both dont have the same outflow what should i do?
cullens089 is offline   Reply With Quote
Old 09-11-2007, 10:42 PM   #4
 
fish_4_all's Avatar
 
If there is any way to increase or adjust the flow then I would max out the flow until both of them spin. Once they are both spinning for a while evenly then you could adjust the flow rate down if needed.

I would check everything in the filter housing as far as media, possible manufacturer inserts that could restrict flow, even distribution of the media, make sure the outflow from the propeler isn't blocked, everything. If there is nothing obvious and you can not get them to spin evenly I would take them back if you can. Otherwise take them to a LFS you trust and let them see if thhey can figure out what is wrong. You can oput the media in a bag in the tank and run an airstone in the tanks until you can get the filters back on the tanks.
fish_4_all is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Question about filter?? zombiefish610 Freshwater Aquarium Equipment 11 03-16-2009 04:48 AM
filter question (meds and filter) tmz Freshwater and Tropical Fish 2 09-20-2008 10:54 PM
Filter question Tubasteve Freshwater Aquarium Equipment 3 08-27-2008 12:31 AM
Filter question Marine1 Saltwater Aquarium Equipment 2 06-13-2007 06:40 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -5. The time now is 12:41 AM.