Biowheel filter not working? - Tropical Fish Keeping - Aquarium fish care and resources
 
LinkBack Thread Tools
post #1 of 4 Old 02-27-2008, 08:42 PM Thread Starter
New Member
 
Biowheel filter not working?

Hello all I purchased a 35 gallon tank with a Penguin Biowheel 330 filter (relatively the same as the penguin 350) and just finished filling it up with purified filtered water. I'm really excited to get this tank up, my first tank! My problem is that my filter turns on, impeller spins but the water does not go through the filter. My buddy had this working last week. How do I get the water to start going through the filter for the first time? I know it sounds dumb but I never used a biowheel filter before. The impeller is spinning and the filter is clean with new biowheels, the other end of the filter dips in about 3 inches into the water. Any help would be greatly appreciated, and sorry for my ignorance thanks.
dolphinsrok is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 02-27-2008, 08:47 PM
you have to add water to the back of the filter.
dallops_of_polyps is offline  
post #3 of 4 Old 02-27-2008, 09:03 PM Thread Starter
New Member
 
Thanks!

I feel really dumb right about now. It is working lovely! I'm so happy about setting up my first tank, the water is very clear, I used crushed coral and thought it would be cloudy at first. I rinsed out the coral pretty good. Next step is to buy a water test kit then some live plants and I'll let it run for at least a week before adding fish (freshwater), can't wait to post pix!
dolphinsrok is offline  
post #4 of 4 Old 02-29-2008, 03:04 AM
New Member
 
rummynose's Avatar
 
congrats on your new tank!
rummynose is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Filter not working!!! Panic attack!!! NoaDon12 Freshwater and Tropical Fish 5 04-09-2010 05:37 AM
Pre-filter for BioWheel HollyinWA Freshwater Aquarium Equipment 18 01-12-2010 09:43 AM
Filter stopped working fishyinpa Freshwater Aquarium Equipment 6 08-20-2009 05:29 PM
Questions about my new Penguin Biowheel Filter Kim Freshwater Aquarium Equipment 8 01-19-2009 07:40 PM
Filter media for BioWheel 400 Willow518 Beginner Freshwater Aquarium 10 08-25-2008 06:39 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome