Lost My Firemouth - Tropical Fish Keeping - Aquarium fish care and resources
Reply
 
LinkBack Thread Tools
post #1 of 13 Old 01-02-2010, 11:06 PM Thread Starter
Member
 
jeaninel's Avatar
 
Aquarium
Lost My Firemouth

Drat! I lost my firemouth this morning. I suspect IP. She had white, stringy poo, had stopped eating, was hiding and towards the end had respiratory problems. I'd treated the tank with Parasite Clear but it wasn't enough. R.I.P Mrs Doubtfire.
Attached Images
File Type: jpg DSCN2605.jpg (41.9 KB, 54 views)

150 Gallon - Mostly American Cichlids
135 Gallon - Angelfish Community
75 Gallon - Odd couple (Polleni/Angelfish)
55 Gallon - African tank
20 Gallon Long - QT
10 Gallon - Empty
jeaninel is offline  
Sponsored Links
Advertisement
 
post #2 of 13 Old 01-03-2010, 09:00 AM
TFK Moderator
 
Romad's Avatar
 
I'm so sorry to hear that. She was beautiful.

RIP Mrs. Doubtfire

Animal testing is a terrible idea; they get all nervous and give the wrong answers.
Romad is offline  
post #3 of 13 Old 01-03-2010, 01:52 PM
Member
 
willow's Avatar
 
sorry for the loss,she was very pretty.

when you set up a new tank,hide an extra
sponge or two behind some decor,that way you have
something seeded for you next filter.
willow is offline  
post #4 of 13 Old 01-03-2010, 04:47 PM
I'm so sorry about your fish! She was pretty.
dramaqueen is offline  
post #5 of 13 Old 01-03-2010, 04:49 PM
Gold Member
 
aunt kymmie's Avatar
 
What a bummer, she was a nice fish. Everyone else in the tank seem healthy?

If you don't stand up for something you'll fall for anything...
aunt kymmie is offline  
post #6 of 13 Old 01-03-2010, 09:50 PM Thread Starter
Member
 
jeaninel's Avatar
 
Aquarium
I'm a little worried about my JD. He also had white, stringy poo. But he is still eating like a pig and acting normal. The sal and tiger barbs seem fine. I just did a water change and will be doing a 3rd and final dose of the Parasite Clear tonight.

150 Gallon - Mostly American Cichlids
135 Gallon - Angelfish Community
75 Gallon - Odd couple (Polleni/Angelfish)
55 Gallon - African tank
20 Gallon Long - QT
10 Gallon - Empty
jeaninel is offline  
post #7 of 13 Old 01-03-2010, 11:17 PM
What a pretty fish...it's so hard to lose pets.

Stephanie's updated tank profiles:
29 gallon 10 gallon
stephanieleah is offline  
post #8 of 13 Old 01-18-2010, 11:06 PM
Member
 
HollyinWA's Avatar
 
Hi,

Sorry to hear about your Firemouth. She was beautiful. You know, one of my platties has that white stringy poo that i have noticed for the last few days. He kind of keeps to himself in the corner at the top. He does come out now and then to play but then goes back up there. I know something is not right. Poor fish. They have to deal with the shipment to the LFS, then they have to come to a new home (here) in a tank that needs to be cycled. The tanks spikes with ammonia, but fortunately, I got them out of there after a few days (with Ammo Lock helping them until it spiked bad) and then put into a nice big tank, but none the least....STRESS. No wonder fish can get sick with things. I am sure his resistence was lowered.

You mentioned that you think your fish had IP. Since my tank is new and still cycling (good readings though), I really do not want to put meds in there. The 14 gallon tank is not yet ready for fish to be put in there. Not sure what else I can do but wait.

Thanks and sorry again for your fish.

~HOlly
HollyinWA is offline  
post #9 of 13 Old 01-19-2010, 12:50 AM Thread Starter
Member
 
jeaninel's Avatar
 
Aquarium
Thanks Holly,
I ended up losing the JD and the sal also. So I am having to start over. It's so upsetting but there's only so much you can do.

You could try medicated food if you can find it. I know that the Jungle Parasite Clear that I used did not affect the bio filter. Hope your platy gets better.

150 Gallon - Mostly American Cichlids
135 Gallon - Angelfish Community
75 Gallon - Odd couple (Polleni/Angelfish)
55 Gallon - African tank
20 Gallon Long - QT
10 Gallon - Empty
jeaninel is offline  
post #10 of 13 Old 01-19-2010, 12:35 PM
Member
 
HollyinWA's Avatar
 
Quote:
Originally Posted by jeaninel View Post
Thanks Holly,
I ended up losing the JD and the sal also. So I am having to start over. It's so upsetting but there's only so much you can do.

You could try medicated food if you can find it. I know that the Jungle Parasite Clear that I used did not affect the bio filter. Hope your platy gets better.
Sorry to hear that. Did you lose them to the same thing.....did they have the same symptoms and in the same tank?

I hope whatever this Platy has it will not transfer to my other fish. I have not even gotten my main fish yet, and I would hate to think there would be something that will be very contagious to other fish.

I remember in the past using a medicated food before. The thing is, if the fish does not feel well enough to eat, it won't help at all. I am not sure if this one is eating. It looks like he may be when I put food right above him. He is in the top right corner now not looking real well. I wonder how much fish feel when they are ill. Gee, I hate this part about having fish.

I have a Clydesdale that is itchy, and I am trying to figure out why and now I am worried about a Platy. With this many pets, it is always one thing or the other.
HollyinWA is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
firemouth southamericancichlidguy23 Cichlids 5 12-11-2009 07:20 PM
New Firemouth jeaninel Freshwater Journals 7 10-20-2009 10:21 PM
Firemouth or...? DragonFish Cichlids 1 05-10-2009 08:37 AM
firemouth taylorg Cichlids 3 01-31-2009 12:02 PM
Firemouth compatibility beetlebz Cichlids 5 12-08-2007 02:16 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome