Anyone have issues getting a filter or pump to start up... - Tropical Fish Keeping - Aquarium fish care and resources
LinkBack Thread Tools
post #1 of 4 Old 09-06-2007, 03:44 PM Thread Starter
New Member
Anyone have issues getting a filter or pump to start up...

when on a timer powerstrip?

I have a venturi pump on a CO2 bio system that doesn't seem to want to start up in the morning. It is on same daytime power bar as my light. When I get home if I unplug and plug it back in, it starts fine.
jkastner19 is offline  
Sponsored Links
post #2 of 4 Old 09-07-2007, 07:25 PM
beetlebz's Avatar
id try JUST hooking up the pump to the timer. it might be possible its just too much for the one timer.

id get a second elcheapo timer just to see if thats it, if itll start on its own that way

Dedicated, converted, lowes / home depot bulb buyer!
beetlebz is offline  
post #3 of 4 Old 09-07-2007, 08:06 PM
Red Sea?

Those little pumps are prone to sticking as they are so tiny. You might try the smallest maxi jet. They have a spot for the tubing as well.
caferacermike is offline  
post #4 of 4 Old 09-07-2007, 11:10 PM Thread Starter
New Member
Ok, I might try both those ideas. Or just get a new diffusing method, but if not powered, I won't be able to have it on a day/night cycle.

A guy on another forum doesn't think its a big deal to keep it running 24/7, says his oxygen levels aren't affected enough at night and his fish are fine. I don't have fish yet but want everything set up right when I do get them
jkastner19 is offline  

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Forum Replies Last Post
Please Help 90 Tank need pump and start help brian l Freshwater Aquarium Equipment 3 06-22-2009 06:48 AM
Need filter/pump for 60g freshwater Sleeper Freshwater Aquarium Equipment 6 12-20-2007 10:28 AM
Filter issues runningmurphy Freshwater Aquarium Equipment 4 05-04-2007 05:09 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome