Can anyone tell me what this is?? - Page 2 - Tropical Fish Keeping - Aquarium fish care and resources
Reply
 
LinkBack Thread Tools
post #11 of 13 Old 03-07-2009, 06:31 AM Thread Starter
New Member
 
Another update,

Just a quick note, the problem that I had in the above pictures disappeared the next day!! But then this new problem started.

Anyway, my favourite fish ended up dying this morning! I also lost another one after lunch That left me with one fish!! Whis is now not looking so good. We thought it was ok but I justspotted it at the bottom with a slight lean which is what the other did too. If this one dies I would have lost 3 Electric Yellows and 3 Electric Blues in a week! Atleast my catfish and sucker fish are unaffected.

I guess I will have to buy some in a few weeks time, once everything has settled in the tank again.
Stap is offline  
Sponsored Links
Advertisement
 
post #12 of 13 Old 03-07-2009, 07:58 AM
Member
 
fishkid's Avatar
 
It could be a cichlid die off. Its when all the cichlids die, and all the other fish arer unaffected. It happened to me, except with characins. If your other fish continue to do fine, I would wait a month before replacing you cichlids.

Everything happens for a reason, but the reason isn't always good.
fishkid is offline  
post #13 of 13 Old 03-08-2009, 04:21 AM Thread Starter
New Member
 
OK I lost the last one this morning That leaves just the two catfish and sucker fish. I cleaned out the filter, cleaned the gravel and topped up the water. I will now leave it a few weeks before I think about adding any more fish.

Thank you for everyone's suggestions and thoughts.

Stacey
Stap is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome