filter issues
Tropical Fish

Tropical Fish Keeping - Aquarium fish care and resources » Freshwater Fish and Aquariums » Freshwater and Tropical Fish » Catfish » filter issues

filter issues

This is a discussion on filter issues within the Catfish forums, part of the Freshwater and Tropical Fish category; --> H,i It has been a long time since I took part in the forum. I will try to be more regular from here on. ...

Check out these freshwater fish profiles
Twig Catfish
Twig Catfish
Spotted Driftwood Cat
Spotted Driftwood Cat
Reply
Old 06-30-2014, 04:31 PM   #1
 
filter issues

H,i It has been a long time since I took part in the forum. I will try to be more regular from here on. I have a 125 gal fresh water tank, planted.
I had a Filstar cannister filter which worked well, till 3 days ago when I came down at 3:00 am to find the intake tube had become disconnected from the assembly.
1/2 of water lost on wood floors,still drying. filter now won't work. Probably motor ran dry. Now to choose a replacement. It is funny, when I bought the filter I never thought about using more substantial clamps on the tubes. Those plastic zip tye types can fail. Any suggestions on a safe good filter? Thanks Liz
lgregory is offline   Reply With Quote
Old 06-30-2014, 05:05 PM   #2
 
Romad's Avatar
 
Hello and welcome to the forum

Sorry to hear about your canister woes. I've got an Rena Filstar on my 75 gallon and it's been running like a charm for 4 years now. They're pretty good with replacing parts or possibly the entire filter so you might want to contact them and tell them what happened before you give up on it.
Romad is offline   Reply With Quote
Old 06-30-2014, 07:16 PM   #3
 
Thanks for the reply, Romad. I have emailed them and am waiting for a reply. Are you trusting those little plastic black holders that fit over the tubes? I went to Lowes and got some steel ones that are used in plumbing. I had my Filstar set up for over a year without problem and just never even thought about it. Liz
lgregory is offline   Reply With Quote
Old 06-30-2014, 09:09 PM   #4
 
Romad's Avatar
 
I honestly don't remember if we used what came standard. I'll have to take a look and let you know.
Romad is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Filter issues runningmurphy Freshwater Aquarium Equipment 4 05-04-2007 05:09 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -5. The time now is 09:49 PM.