brackish cycling woes - Tropical Fish Keeping - Aquarium fish care and resources
 
LinkBack Thread Tools
post #1 of 2 Old 11-20-2008, 12:47 PM Thread Starter
brackish cycling woes

Has anyone else had trouble cycling a mid-high brackish tank?

My mudskipper tank is generally 0.10-0.11 - it's been six weeks and the darn thing still isn't cycled! I don't have ammonia readings and my nitrates are low, but my nitrite is spiking constantly.

It's not such as issue for the mudskipper but I foolishly added some bees and a dragon goby thinking I could stay on top of it with bottled bacteria, amquel+ and water changes - but after all this time I still have to change the water constantly.

(FYI I have 15 gallons of water in a 20g tank, and a duetto 100 submersible filter)

Any thoughts/suggestions?

Thanks!

Jonathan

1 Red Ear Slider - Terra
1 Cocker Spaniel - Zoey
1 Mudskipper - Pangea
3 Bettas - Mars, Venus & Neptune
20g FW community tank
30g SW tank: porcupine puffer, fiji puffer, clown fish
Aquarius Keeper is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 11-20-2008, 01:58 PM Thread Starter
Of course I mean the salinity is 0.010 and 0.011...

1 Red Ear Slider - Terra
1 Cocker Spaniel - Zoey
1 Mudskipper - Pangea
3 Bettas - Mars, Venus & Neptune
20g FW community tank
30g SW tank: porcupine puffer, fiji puffer, clown fish
Aquarius Keeper is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
New set up woes SueK Beginner Freshwater Aquarium 4 09-30-2009 02:51 PM
Cycling a new brackish tank hardflip2heavan Brackish Water 5 08-27-2008 02:49 PM
Brackish water cycling (QUESTION) TFHJ Brackish Water 7 05-14-2008 08:48 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome