Red slime...help!
Tropical Fish

Tropical Fish Keeping - Aquarium fish care and resources » Saltwater Fish and Coral Reef Tanks » Beginner Saltwater Aquariums » Red slime...help!

Red slime...help!

This is a discussion on Red slime...help! within the Beginner Saltwater Aquariums forums, part of the Saltwater Fish and Coral Reef Tanks category; --> After 6 months, I am still efforting tirelessly to get my tank to become a thriving livable habitat. I've gone through 6-8 fish so ...

Check out these saltwater fish profiles
Black And White Percula Clownfish
Black And White Percula Clownfish
Black And White Percula Clownfish
Black And White Percula Clownfish
Reply
Old 10-12-2011, 10:03 PM   #1
 
Red slime...help!

After 6 months, I am still efforting tirelessly to get my tank to become a thriving livable habitat. I've gone through 6-8 fish so far. 3 different attempts to get it going.
Now I have an arrow crab that has survived 2 of those attempts and is doing fine. I have come to the conclusion that I don't think I have enough water flow.
I have a 75 gal tank with a sump. My sump set up has a protein skimmer which appears to be doing the job.
My water tests ok or so I've been told.
However, here's the obit...
3 chromies...
1 lived to see the next generation...which was 2 firefish another chromie and the arrow crab.
Homie the chromie ate the new chromie and the firefish were never to be seen again...eventually homie died as well.
I did a 30% water change. then added 1 bi colored angel, 2 clowns and 3 sea catfish (which were cool and looked like mimi sharks)..
Now 3 weeks later...all are dead and the arrow crab lives on. I have a red slime issue.
Any suggestions on red slime cure and am i missing anything else besides water flow that might be hindering my performance??
Please help!
Thanks
Salty1 is offline   Reply With Quote
Old 10-12-2011, 10:21 PM   #2
 
Quote:
Originally Posted by Salty1 View Post
After 6 months, I am still efforting tirelessly to get my tank to become a thriving livable habitat. I've gone through 6-8 fish so far. 3 different attempts to get it going.
Now I have an arrow crab that has survived 2 of those attempts and is doing fine. I have come to the conclusion that I don't think I have enough water flow.
I have a 75 gal tank with a sump. My sump set up has a protein skimmer which appears to be doing the job.
My water tests ok or so I've been told.
However, here's the obit...
3 chromies...
1 lived to see the next generation...which was 2 firefish another chromie and the arrow crab.
Homie the chromie ate the new chromie and the firefish were never to be seen again...eventually homie died as well.
I did a 30% water change. then added 1 bi colored angel, 2 clowns and 3 sea catfish (which were cool and looked like mimi sharks)..
Now 3 weeks later...all are dead and the arrow crab lives on. I have a red slime issue.
Any suggestions on red slime cure and am i missing anything else besides water flow that might be hindering my performance??
Please help!
Thanks
Well, not that I dont trust your water readings, but what exactly are they? Ammonia-Nitrites-Nitrates-Phosphates?
I'll give you just a heads up, if you have any readings at all in the Ammonia or Nitrites you are still in trouble adding fish.
Next, Cyano is normal for a tank with not enough flow. You should have at least 750gph minimum to start. If you still have a deaad water spot issue, you need more flow. But some just use one powerhead, I would recommend having 2. One on each side of the glass pointing inward, your tank I would start with 2 400gph powerheads.
Red Slime Algae (Cyanobacteria) - Description, causes and cures for Red Slime Algae (Cyanobacteria)
Reefing Madness is offline   Reply With Quote
Old 10-12-2011, 11:01 PM   #3
 
wannalearn's Avatar
 
agreed, you said your water reading were OK, so you were told, what are they exactually,you really need to know , and understand what they are, and what they mean, so that you dont have to rely on ( ok, so you were told)
wannalearn is offline   Reply With Quote
Old 10-13-2011, 05:17 AM   #4
 
Pasfur's Avatar
 
My immediate thoughts would focus on alkalinity and calcium, in addition to water flow. We can help fix your problems, we do it all the time. First, we need complete details of your setup, including test results, and pictures would be very helpful.
Pasfur is offline   Reply With Quote
Old 10-14-2011, 03:32 PM   #5
 
trukgirl's Avatar
 
Sounds like you were also adding way too many fish at one time. One per week in a new tank MAXIMUM, not 3-4 at a time.

+1 on what Pasfur said. Phosphates can also affect Cyanobacteria (which is USUALLY what red slime is)

I had 2 - 750 gph powerheads in my 65g plus a 700 gph return pump, and I still ended up with a dead spot in my tank. Do you have any powerheads?
trukgirl is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Slime? nofinga911 Beginner Freshwater Aquarium 3 09-18-2007 08:39 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -5. The time now is 05:13 AM.