New Tank Up And Running but need help...? - Tropical Fish Keeping - Aquarium fish care and resources
 
LinkBack Thread Tools
post #1 of 4 Old 04-22-2010, 05:23 PM Thread Starter
New Member
 
New Tank Up And Running but need help...?

Hi everyone

So I have a Marine tank (Main Tank 122cm length 38cm Width 60cm Height) with a sump (Sump 91cm Length 25cm Width 45cn Height)

I have just finished rigging it all up (Well I have the Lights to fit tomorrow)

I have filled the tank with water (tap) to ensure all is working and everying is working as it should be.

I have a the water dripping through the top chamber though a drill hole going into the 1st chamber where the skimmer is (600l v2 protein skimmer) Nothing as yet in the 2nd chamber and a return pump in the 3rd chamber going back into the tank.

I have currantly two power heads in the tank ready (1 x Koralia evolution flow rate 5200 and 1 x 4000)

I have 25kg of Kent Sea Salt.

what do I need to add to the water before putting the sea salt into the tank....?

I want to be adding live rock in the tank as soon as i can do with coral sand...?

Want to be sure on the next step







Thanks Phil
philabsolom is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 04-22-2010, 09:51 PM
Member
 
wake49's Avatar
 
Are you doing corals?



Nothing good happens fast in an Aquarium

My 30 Gallon Long Marine Tank
My son's 20 gallon FW Community
wake49 is offline  
post #3 of 4 Old 04-23-2010, 06:23 AM Thread Starter
New Member
 
I will be adding Corals yes....?
philabsolom is offline  
post #4 of 4 Old 04-23-2010, 02:49 PM
Member
 
wake49's Avatar
 
I use only RO/Di water in my reef tank. Tap water can have heavy metals (and other things that Prime cannot take care of) that are harmful to corals. Most water travels through copper pipes and copper in even lower levels has an adverse effect on corals. Do you have well or city water?



Nothing good happens fast in an Aquarium

My 30 Gallon Long Marine Tank
My son's 20 gallon FW Community
wake49 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Got my 39g+ running!!!! Silverthorne Freshwater Journals 25 03-07-2010 12:44 PM
Got my tank up and running... Some questions/comments skimmer247 Beginner Saltwater Aquariums 2 09-07-2008 05:54 PM
125g tank up and running spawnie9600 Cichlids 11 02-29-2008 05:35 AM
new tank, running a little hot conger Saltwater Aquarium Equipment 4 02-03-2008 08:22 PM
so my tank is up and running bobo Beginner Saltwater Aquariums 7 02-02-2008 06:24 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome