green hair algae HELP!
Tropical Fish

Tropical Fish Keeping - Aquarium fish care and resources » Saltwater Fish and Coral Reef Tanks » Beginner Saltwater Aquariums » green hair algae HELP!

green hair algae HELP!

This is a discussion on green hair algae HELP! within the Beginner Saltwater Aquariums forums, part of the Saltwater Fish and Coral Reef Tanks category; --> i started my tank about 7 months ago. about two months ago green algae started to grow about the time i got my strip ...

Check out these saltwater fish profiles
Naso Tang
Naso Tang
Porcupine Puffer
Porcupine Puffer
Reply
LinkBack Thread Tools vBmenu Seperating Image Search this Thread vBmenu Seperating Image
green hair algae HELP!
Old 06-11-2007, 12:17 AM   #1
 
green hair algae HELP!

i started my tank about 7 months ago. about two months ago green algae started to grow about the time i got my strip light. it's one 10000k and one blue acintic. i have a regal tang, a domino damsel, a cleaner shrimp about twenty hermit crabs and two turbo snails i bought recently to help with the algae. also i'm still reading no nitrates at all in the tank, and i dont have a phosphate test. i got some water from the lfs to see if something might be wrong with my kit but it read nitrate in there water. i thought this might have something to do with the algae. any information on how to fix this problem? also i bought some snails a while back and they all died. maybe this can help determine the proble. thanks.
blackta3 is offline   Reply With Quote
Old 06-11-2007, 12:19 AM   #2
 
also i forgot to mention i only run my lights 6 hours a day.
blackta3 is offline   Reply With Quote
Old 06-11-2007, 01:10 AM   #3
 
anemone's Avatar
 
You need to check your phosphates
anemone is offline   Reply With Quote
Old 06-11-2007, 10:03 PM   #4
 
hi i just added a phosphate absorber.do you think this will do the job? i dont have a phosphate test so i took a sample to the lfs and they couldn't test for phosphate. i found a test but it was 20 dollars. since i have the phosphate absorber do you still think i need a test? also what are the chances phosphate is my problem?
blackta3 is offline   Reply With Quote
Old 06-11-2007, 10:17 PM   #5
 
anemone's Avatar
 
Hopefully the link below help you understand better

cheers




http://saltaquarium.about.com/gi/dyn.../lib3/phos.htm
anemone is offline   Reply With Quote
Old 06-18-2007, 08:10 PM   #6
 
ok i tested my phosphate and it is zero. hair algae is still growing and i also have brown algae. my nitrate is undetectable. seems like i should have at least a little nitrate since the other tank i have has about 10ppm and i started them at the same time. should i get a protein skimmer? will that help. someone please help me.
blackta3 is offline   Reply With Quote
Old 06-18-2007, 08:25 PM   #7
 
Quote:
Originally Posted by blackta3
ok i tested my phosphate and it is zero. hair algae is still growing and i also have brown algae. my nitrate is undetectable. seems like i should have at least a little nitrate since the other tank i have has about 10ppm and i started them at the same time. should i get a protein skimmer? will that help. someone please help me.

One get a skimmer. As for the hair algea. You need to remove the rock and scrub the algea off. Dont do this in the tank. As it will spread and cause more problems. What tests are you using?
usmc121581 is offline   Reply With Quote
Old 06-18-2007, 10:07 PM   #8
 
for the phosphate i'm using an api test and for nitrate and everything else i'm using a doc well fish tesk kit. i will take the rock out and scrub it and see if that helps. does a protein skimmer remove phosphate?
blackta3 is offline   Reply With Quote
Old 06-19-2007, 08:38 PM   #9
 
if anyone else is having this problem look at this site. http://www.amdareef.com/ho_algae.htm
blackta3 is offline   Reply With Quote
Old 06-19-2007, 10:41 PM   #10
 
i still need an answer to why i still have no nitrates. i have taken my water to two different lfs and all of them read zero. why is this?
blackta3 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
hair algae walkytalky Beginner Saltwater Aquariums 17 01-12-2009 02:07 PM
GREEN HAIR ALGEA seba Saltwater Fish Diseases 2 05-20-2008 05:52 PM
EEEK not so nice green hair algae bullseye69 Beginner Planted Aquarium 2 09-07-2007 01:52 AM
Long Green Hair Puffer Beginner Saltwater Aquariums 1 07-30-2007 06:58 PM
hair algae fiona Beginner Freshwater Aquarium 2 10-07-2006 03:38 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -5. The time now is 03:56 AM.