Green Algea - Tropical Fish Keeping - Aquarium fish care and resources
LinkBack Thread Tools
post #1 of 26 Old 06-02-2009, 07:19 PM Thread Starter
New Member
Green Algea

Hi all I'm new, and have a reef tank, 1200*600*500 and I have this problem of green algae, I have tried everything to try and get rid of it but it just continues to grown seemingly overnight, We lost all our corals and fish bar one female marroon clown fish. We cleaned the whole tank out, brought in some new live rock. and kept some of the old. we cahnge the water at the start every three days, now we do it weekly, normally 60 litres. The test for phosphates and nitrates are low, so I would like to know if I am doing something wrong.
Nessie is offline  
Sponsored Links
post #2 of 26 Old 06-02-2009, 09:19 PM
onefish2fish's Avatar
what kind of skimmer, lights, feeding routine, types of food, exact water parameters, depth of sand bed/substrate, sump/filtration?, size of tank?, how old is it?, exactly what kind of green algae? like grass?, anything and everything else you can include. pictures help.

welcome to the forum.
onefish2fish is offline  
post #3 of 26 Old 06-03-2009, 03:12 AM Thread Starter
New Member
Originally Posted by onefish2fish View Post
what kind of skimmer, lights, feeding routine, types of food, exact water parameters, depth of sand bed/substrate, sump/filtration?, size of tank?, how old is it?, exactly what kind of green algae? like grass?, anything and everything else you can include. pictures help.

welcome to the forum.
HI there, I am attaching a heap of photo's. The tank is actually now about 5-6yrs old but it started to get this algae about 18mths ago and have since slowly lost everything in it's path, I am only a learner and relied on advise from local fish stores. I did every thing they asked I changed food from frozen to dry I only feed now becuase I have 1 main fish left and I bought 2 green chroimi's and 2 domino damsels for water testing a very small amount two times a day. But I still have this blasted green algae growing it is becoming really frustrating, I have been treating the water every three days with Algae kill and have gone through almost two bottles now, I need advise BIG TIME. Hope the photo's help I have no idea what green algae it is.

Nessie is offline  
post #4 of 26 Old 06-03-2009, 07:07 AM
onefish2fish's Avatar
IMO i wouldnt use any algae chemicals esp when the problem isnt fixed so its a temp solution. it also could be trouble using things like this in a reef or any saltwater tank for that matter.

just from what i see in the pictures your going to want to remove the bio balls. these are great for a freshwater setup but for saltwater they trap debris and detritus building up excess nutrients causing algae blooms like this. are you using RO/DI water? how old are the bulbs? the more info you can include the better we can help
onefish2fish is offline  
post #5 of 26 Old 06-03-2009, 11:36 PM Thread Starter
New Member
Ok Ill stop the treatment it wasn't doing any good anyway. I brought two of the white light bulbs a few months ago, the store didn't have aymore so have been waithing for stock to arrive, I am due also to update my blue lights. Do you think these may be contributing to the problem. I'm not sure what RO/DI water is, we live out in the bush here in Australia and have only bore water,or rain water, we have had it tested on a regular basis and it is very pure. When all our fish died we cleaned out the whole tank, including the Bio Balls which were full of awful smelling stuff, but we were told to put them back in and when we had the tank up and running smoothly, start to take them out a few at a time to get the tank to slowly use the live rock instead, is this correct?. The tank has never come good though so have not started to remove the balls. Should I just remove them all at once or Gradually?? Thank you so much for your help, I really appreciate it.
Nessie is offline  
post #6 of 26 Old 06-03-2009, 11:55 PM
conger's Avatar
remove them gradually, that way you don't disturb the bacteria population in the tank and you let the bacteria in your liverock and sandbed multiply to make up for the removed balls, without going through a mini-cycle.

It looks like your skimmer is working well, lots of good gunk in the collection cup . If you have other mechanical filtration in the system (sponge blocks, filter socks, etc...) you might consider removing them too, or at least rinse them out very frequently, otherwise they will pose the same problem as the bioballs (trapping junk and allowing nutrients to build up). How large is your tank, and how many pounds of liverock do you have? Assuming you have sufficient liverock, then the liverock and skimmer together should be plenty of filtration for your tank, perhaps eliminating the bioballs and possibly sponges/socks if you have them will help.

Good luck!

"To an optimist, the glass is half-full;
to a pessimist, the glass is half-empty;
to an engineer, the glass is twice as big as it needs to be"
conger is offline  
post #7 of 26 Old 06-03-2009, 11:57 PM
onefish2fish's Avatar
remove them over time. a handfull every few days or once a week. how much live rock do you have? good flow, a quality skimmer, enough live rock, good feeding habbits and a water change here and there should be the basics of your filtration. you can also have a UV sterilizer and carbon/phosban reactors ( which i suggest )
sumps are good to for added water volume and a place to hide this stuff.
your water source may be the contributer to this. RO/DI is reverse osmosis water which is filtered water. your water may be high in phosphates and/or other trace minerals feeding your algae in your water source.
onefish2fish is offline  
post #8 of 26 Old 06-04-2009, 05:13 AM Thread Starter
New Member
Hi Again one fish, I tested our water supply with no traces at all to phosphates or nitrates, and Conger thankyou and one fish for that advise on the bio balls, Iwill start to take them out a little every week, I;m not sure of the exact weight of live rock I have in the tank at the moment, I will have to try and weigh it, is it important to know this figue??? I know I pulled alot out and have about a third of my original amount, but will try and get a true weight for you.
Nessie is offline  
post #9 of 26 Old 06-04-2009, 06:40 AM
onefish2fish's Avatar
no need to pull it out and weigh it. i was just wondering how much you had.
onefish2fish is offline  
post #10 of 26 Old 06-04-2009, 07:00 AM
Kellsindell's Avatar
The reason your test kits aren't reading NO3 and PO4 is because they are bound in the algae. If you didnt have any of those minerals, you wouldn't have algae. You need to manually pluck the GHA out of the tank. Get a bowl full of water and pluck a pinch full out of the tank. Then dip your hand in the bowl to rinse the GHA and any spores released into the freshwater and then do it again. Yes, it sucks, but manual removal is the best. You then need to do a water change, 10%, and try to catch any GHA that's free floating. Then the next day, do it again and then the next day and you'll see you'll have success this way. I never recommend scrubbing the rock as that is only temporary and the roots just grow right back.

This could be the result of the bio-balls releasing finally and it's messing your parameters up.

And God said, Let us make man in our image, after our likeness: and let them have dominion over the fish of the sea...

75g Build

Kellsindells build

2.5 Pico Build

Member of DFWMAS ... PBITAWA
Michael Hernandez
Kellsindell is offline  

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Forum Replies Last Post
Algea explosion! My water is Green... what to do? strawnj Beginner Freshwater Aquarium 13 03-23-2010 08:53 PM
green nasty looking algea :( dolphinsrok Beginner Freshwater Aquarium 1 09-23-2008 10:59 PM
Rid of green algea milindsaraswala Beginner Planted Aquarium 0 07-16-2008 01:08 PM
GREEN HAIR ALGEA seba Saltwater Fish Diseases 2 05-20-2008 04:52 PM
bright green algea black&whiteclowns Saltwater Fish Diseases 3 04-30-2007 05:10 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome