Cycling Problem - Tropical Fish Keeping - Aquarium fish care and resources
LinkBack Thread Tools
post #1 of 4 Old 02-26-2008, 12:22 AM Thread Starter
New Member
Cycling Problem

Every time i check my sg it says something different like 1.015 and 1.032.
What is the problem?
Bandit4575` is offline  
Sponsored Links
post #2 of 4 Old 02-26-2008, 11:06 AM
New Member
Puffer's Avatar
If your using a Plasic one ,Make sure you bang it flat on the counter to get all the little air bubbles off the Gage.

Vistit Burch Aquarium CAL.
Puffer is offline  
post #3 of 4 Old 02-26-2008, 11:35 AM
MattD's Avatar
Ensure there is no flow interfering with the readings. Be sure after eah time you use it, you clean it since dissolved salt will stick to the unit.

Tanks: 40 gal FW setup, 10 gal Reef tank.

Old BC8 setup:
MattD is offline  
post #4 of 4 Old 02-26-2008, 02:35 PM
bettababy's Avatar
Unfortunately hydrometers can be very inaccurate. It has to do with the temp changes during production. If you know someone with a refractometer, ask them to calibrate it for you. Your best bet would be to invest a bit of money and purchase your own refractometer. This is a piece of equip that is well worth the money for anyone keeping saltwater, as it is used all the time and is the most accurate reading available.

Dawn Moneyhan
Aquatics Specialist/Nutritionist
Juneau, WI
bettababy is offline  

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Forum Replies Last Post
ammonia/ ammonium??? cycling problem turkeyofthesea Beginner Freshwater Aquarium 5 03-30-2009 12:33 AM
Cycling with Biozyme? instant cycling Livelifelaughlove Freshwater and Tropical Fish 2 03-22-2009 11:23 AM
cycling problem - can u help? afishianado Introduce Yourself 6 03-11-2009 05:34 AM
Fishless Cycling & Ammonia problem... EricTViking Beginner Freshwater Aquarium 3 11-06-2007 03:27 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome