Algea problem? - Tropical Fish Keeping - Aquarium fish care and resources
 
LinkBack Thread Tools
post #1 of 3 Old 12-17-2007, 02:35 PM Thread Starter
New Member
 
Algea problem?

My tank is now a very dark green, I can't even see the fish anymore, is this because of my filter, or is it algea? Everytime I clean the tank, it stays clear for a day or two, but then goes back to dark green! Should I get a new filter, and how do I fix this?
FrostMan242 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 12-17-2007, 03:50 PM
Member
 
MattD's Avatar
 
Check your phosphate levels and drastically reduce your lighting periods. Cut back on feeding as well, you're only fueling the nutrients even more.

Good luck.

Tanks: 40 gal FW setup, 10 gal Reef tank.

Old BC8 setup: http://www.fishforum.com/viewtopic.php?t=10744
MattD is offline  
post #3 of 3 Old 12-18-2007, 09:21 AM
Also try changing the filter media a little more often (Like once a week or so) until it clears. I wouldn't leave the lights on for more than 4 hours until it clears up, then set them to go for 8-10 hours after it clears.
Age of Aquariums is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Algea help - what algea cleaners do you use saulat Beginner Planted Aquarium 20 06-08-2013 02:08 AM
when to add algea seba Saltwater Aquarium Equipment 6 03-04-2008 08:50 PM
red algea trreherd Beginner Saltwater Aquariums 4 06-05-2007 11:59 AM
algea cp5041 Water Chemistry 2 02-16-2007 04:45 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome