Algae's the latest problem! - Tropical Fish Keeping - Aquarium fish care and resources
LinkBack Thread Tools
post #1 of 4 Old 04-19-2014, 10:52 AM Thread Starter
New Member
Algae's the latest problem!

Enjoying this new hobby - challenge after challenge!
I have a brown/ green algae that appears on the sand and live rocks. It grows incredibly quickly, and can appear half a day after raking the sand or cleaning the glass.

I have a small clean up crew and two clowns. 195 litre aqua one tank. Nitrate less than 5. Nitrite and ammonia nil and pH about 8.3. I leave the lights on for about 10 hours a day. I feed sparingly, any thoughts on fish that might solve it for me or are there any other solutions?

Many thanks

Last edited by MartinLB; 04-19-2014 at 10:56 AM.
MartinLB is offline  
Sponsored Links
post #2 of 4 Old 04-19-2014, 05:12 PM
Reference Team
badxgillen's Avatar
How long has the tank been setup,it is all part of the cycle if you tank is only a few months old? What are the phosphates? You can include macro algaes to compete for nutrients or add some chemical filtration to absorb excess nutrients.Then decrease the photo period, increase flow, and possibly add some more snails\hermits.

badxgillen is offline  
post #3 of 4 Old 04-20-2014, 01:35 PM Thread Starter
New Member
I will need to check phosphates - the tank is less than two months old.

Thanks for the tips
MartinLB is offline  
post #4 of 4 Old 04-20-2014, 11:27 PM
Reference Team
badxgillen's Avatar
There could also be diatoms feeding off of silicates.

badxgillen is offline  

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help algae problem Calmwaters Beginner Planted Aquarium 24 10-19-2010 01:00 PM
Algae Problem milindsaraswala Beginner Planted Aquarium 1 05-26-2010 11:12 AM
algae problem jennifer3108 Tropical Fish Diseases 7 04-21-2007 12:56 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome