Why is my plant disapearing bit by bit...
Tropical Fish

Tropical Fish Keeping - Aquarium fish care and resources » Freshwater Fish and Aquariums » Beginner Freshwater Aquarium » Beginner Planted Aquarium » Why is my plant disapearing bit by bit...

Why is my plant disapearing bit by bit...

This is a discussion on Why is my plant disapearing bit by bit... within the Beginner Planted Aquarium forums, part of the Beginner Freshwater Aquarium category; --> This is the first time i see this in my tank, the plants leafs are begining to dissapear, holes are appearing in the leafs ...

Reply
LinkBack Thread Tools vBmenu Seperating Image Search this Thread vBmenu Seperating Image
Why is my plant disapearing bit by bit...
Old 02-21-2010, 05:15 PM   #1
 
Redknee's Avatar
 
Why is my plant disapearing bit by bit...

This is the first time i see this in my tank, the plants leafs are begining to dissapear, holes are appearing in the leafs and they are turning brownish around those holes.
Any idea why?
Pic:
Redknee is offline   Reply With Quote
Old 02-21-2010, 09:27 PM   #2
 
Austin's Avatar
 
Well I think it could be many things. Maybe your plant is losing it's leafs. Leafs do die after a bit but should be replaced with new ones. If they are not being replaced with new ones or the new ones look yellowish or unhealthy you might not have adequate lighting or nutrients. If you have any fish they might be nipping at them.
Austin is offline   Reply With Quote
Old 02-21-2010, 09:48 PM   #3
 
aunt kymmie's Avatar
 
I had some leaves look like that quite a bit of time ago. It turns out that the nutrient level in my tank was out of whack due to overdosing with potassium. I stopped dosing potassium (thank you, Bryon) and all was back in balance and the leaves stopped "falling apart".
Your leaves look like they may be suffering a nutient deficency. What type of lighting do you have on your tank, how many hours do you run the lights and what ferts, if any, do you use?
aunt kymmie is offline   Reply With Quote
Old 02-22-2010, 10:31 AM   #4
 
Redknee's Avatar
 
Got 4 30W phillips aquarelle neons as for fertilizers i use: JBL balls(the nut size ones made from... some clay thingy) + JBL Ferropol + Sera Flore Plant all of them in the recommended dose.
No fertile substrate just black quartz(not painted, natural black quartz).
Thanks for the input!
Redknee is offline   Reply With Quote
Old 02-22-2010, 11:07 AM   #5
 
Angel079's Avatar
 
What size tank do you have the 4x30w over? I pers never had these lights your ref to; do you by chance know the Kelvin rating of these?
Looking at the pic's its a nutrition deficit to me; meaning to balance your lights and ferts better. These JBL Balls do you have a specific name there or maybe even still the package they came in to see what's in these balls as far as ingredients?
Angel079 is offline   Reply With Quote
Old 02-22-2010, 12:56 PM   #6
 
Redknee's Avatar
 

Those ar ethe JBL balls i use.
Item info:
JBL The 7 Balls are pressed fertilizing pellets, enriched by a special process with all the nutrients vital for aquatic plants, especially iron and trace elements. The nutrients are released slowly, providing a very favourable depot effect. The ball shape permits the convenient use in existing freshwater-aquariums. Specially suitable for the specific nutrient supply or post-fertilization of aquatic plants which mainly absorb their nutrients through the roots, such as echinodori, cryptocory-nae, and others.For long-term root fertilising in an established aquarium.
Does not contain phosphates and nitrates.
Contains iron and minerals in a form readily accessible for plants to absorb through the roots.
Use:
Depending on size of the aquatic plant, press one or more balls into the ground around the roots. Repeat after one year.

Last edited by Redknee; 02-22-2010 at 01:01 PM.. Reason: Causse i'm dumb :)
Redknee is offline   Reply With Quote
Old 02-24-2010, 12:07 PM   #7
 
Byron's Avatar
 
The JBL root balls sound OK to me, from what I read there. You may however need liquid fertilization as well. But before getting into that, and having taken another look at your photo: can you post a photo of the entire sword plant (the plant in the photo is a sword, Echinodorus bleheri I suspect)? I want to see all the leaves from top- to crown at the substrate. Also, how long have you had this plant. Then I'll be able to say more.

The Vallisneria (or possibly a Sagitarria) in the photo has the ends cut off, were they dying?

Byron.
Byron is offline   Reply With Quote
Old 02-25-2010, 02:38 PM   #8
 
Redknee's Avatar
 
Well Byron the vallisneria had tons of algae on it and i used the... how do u call it in english...medicinal alcohol? method to kill the algae. Wha tu do is dip the plant(except roots) in medicinal alcohol for 10-20 seconds. It did wonders for MOST my plants with algae but the vallisneria seemed to not like getting drunk... So it kinda died from top to the middle and i had tu cut it.
As for the Echinodorus i'll try in the morning to get a decent pic of it top to bottom.
Thanks for the reply!
Redknee is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
the amazing disapearing tetras Tomsk Freshwater and Tropical Fish 5 04-07-2010 04:09 PM
Algae on plant leaves, harmful to plant? poolman84 Beginner Planted Aquarium 14 03-09-2010 10:31 AM
Identify plant and suggestions on plant arrangements saulat Beginner Planted Aquarium 3 06-22-2009 07:04 PM
ATTN Plant Xperts.....Need plant help (newbie ?) bigk_54 Beginner Planted Aquarium 10 09-09-2008 08:13 AM
My fish are disapearing CB-Sunshine Tropical Fish Diseases 9 04-18-2008 04:01 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -5. The time now is 10:51 PM.