um.. what's this growing on my Amazon Swords?
Tropical Fish

Tropical Fish Keeping - Aquarium fish care and resources » Freshwater Fish and Aquariums » Beginner Freshwater Aquarium » Beginner Planted Aquarium » um.. what's this growing on my Amazon Swords?

um.. what's this growing on my Amazon Swords?

This is a discussion on um.. what's this growing on my Amazon Swords? within the Beginner Planted Aquarium forums, part of the Beginner Freshwater Aquarium category; --> I tried my best to take pictures of the stuff growing on my plants and tank walls. Anyone have any idea what's going on? ...

Reply
LinkBack Thread Tools vBmenu Seperating Image Search this Thread vBmenu Seperating Image
um.. what's this growing on my Amazon Swords?
Old 11-25-2011, 08:18 PM   #1
 
um.. what's this growing on my Amazon Swords?

I tried my best to take pictures of the stuff growing on my plants and tank walls. Anyone have any idea what's going on? It really started after we added carbon to the hob filter. The plants went to heck pretty fast, so we removed the carbon and they never really recovered and this stuff went nuts growing all over the plants and walls. If I have to I will remove these plants and get new ones, but I don't want to do that until I know I can be assured that whatever this is won't grow on the new plants.


Gina

53400210.jpg

53400214.jpg
ginagv is offline   Reply With Quote
Old 11-25-2011, 10:01 PM   #2
 
Calmwaters's Avatar
 
It kind of looks like Black Brush Algea but I can't see it in the pictures very well. Does it looks like this:

If so how long has it been since you changed your light bulbs? I recently had a battle with this and lost alot of my plant but with the help of others here I relized it had been almost 1.5 year since I changed my lights so I trimmed off the leaves that had it from the few plants I had left scrubbed the driftwood and decor and switched the bulbs and so far so good the algea has not come back.
Calmwaters is offline   Reply With Quote
Old 11-25-2011, 10:16 PM   #3
 
MinaMinaMina's Avatar
 
Yes, its hard to tell. Could it also be diatoms + a wee bit of hair algae? A closer look would be helpful. But that would be my first guess because it looks like you have some diatoms on the glass in the first pic.
MinaMinaMina is offline   Reply With Quote
Old 11-26-2011, 03:09 AM   #4
 
hmm.. I thought diatoms were only found in new tanks.. mine's been going for a year or so.. No fish deaths in that time either... Everyone is happy.. plants just look terrible.

I have consulted another hobbyist and he suggested that I cut the swords down to about 1/4 inch above the roots and let them all regrow their leaves. My crypt did that naturally when all the plants started to affected, and the new crypt leaves are coming in nice and dark green, with no brown areas or spots at all.


Gina
ginagv is offline   Reply With Quote
Old 11-26-2011, 03:39 AM   #5
 
MinaMinaMina's Avatar
 
Diatoms are pretty par for the course in new tanks, but can happen other times. Some say that its a "gateway algae", meaning its the first sign of more to come. What are your nitrate readings? Do you have anything in the tank that eats algae? And if so, how does that critter respond to this type of algae?
MinaMinaMina is offline   Reply With Quote
Old 11-26-2011, 08:13 AM   #6
 
Calmwaters's Avatar
 
If it is also growing on your tank walls cutting the swords back will not help you need to find the root of the cause. What kind of lighting do you have and how long has it been since you changed the light bulb.
Calmwaters is offline   Reply With Quote
Old 11-26-2011, 01:31 PM   #7
 
Byron's Avatar
 
I wold say that is brush algae, I get it. Reducing the light duration is normally necessary, but there are some issues with the swords here. Are you fertilizing at all, and if yes, with what and how often? And what is the light (be specific)?

Byron.
Byron is offline   Reply With Quote
Old 11-27-2011, 08:26 AM   #8
 
Inga's Avatar
 
Glad I found this thread, it is exactly what is happening to my plants. ALL of them. I do huge and frequent water changes so that isn't it. I just changed my light bulbs and hope that will help. I might need to fertilize the larger root plants with some root tabs as it has been awhile but I do add the Seachem's comprehensive fertilizer. It happened suddenly in my tank and has proved quite difficult to get rid of. I think I will cut all my plants down and start anew. :(
Inga is offline   Reply With Quote
Old 11-27-2011, 08:41 AM   #9
 
Calmwaters's Avatar
 
Inga that is what I did after I replaced the light bulbs and so far the algae has not come back so hopefully it will work for you. I just trimmed of the leaves that had the algae and left the rest.
Calmwaters is offline   Reply With Quote
Old 11-27-2011, 08:59 AM   #10
 
Inga's Avatar
 
Quote:
Originally Posted by Calmwaters View Post
Inga that is what I did after I replaced the light bulbs and so far the algae has not come back so hopefully it will work for you. I just trimmed of the leaves that had the algae and left the rest.

Sadly, there won't be much left. I shouldn't have waited so long. I kept hoping that a miracle would occur. That and I was too busy to get to far into the project knowing it was a time consuming one. I will be for the most part, plantless. I hate that. I will also need to remove the wood and scrub, maybe re-boil it?
Inga is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
5 Amazon Swords jschristian44 Beginner Freshwater Aquarium 23 01-30-2011 04:13 PM
Amazon Swords Welsh Beginner Planted Aquarium 4 11-27-2010 07:23 PM
Amazon Swords? koolman56 Beginner Planted Aquarium 13 11-15-2006 12:45 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -5. The time now is 01:37 AM.