There is no algae in my fish tank and I want to grow plants
Tropical Fish

Tropical Fish Keeping - Aquarium fish care and resources » Freshwater Fish and Aquariums » Beginner Freshwater Aquarium » Beginner Planted Aquarium » There is no algae in my fish tank and I want to grow plants

There is no algae in my fish tank and I want to grow plants

This is a discussion on There is no algae in my fish tank and I want to grow plants within the Beginner Planted Aquarium forums, part of the Beginner Freshwater Aquarium category; --> I have my 15 gallon fish tank for a good year with 2 goldfish in it and throughout the year I haven't seen any ...

Reply
LinkBack Thread Tools vBmenu Seperating Image Search this Thread vBmenu Seperating Image
There is no algae in my fish tank and I want to grow plants
Old 08-21-2007, 10:59 AM   #1
 
There is no algae in my fish tank and I want to grow plants

I have my 15 gallon fish tank for a good year with 2 goldfish in it and throughout the year I haven't seen any algae of any sort inside the tank. I don't turn the fluorescent lamp (15 watts) that long - 2 hours a day. The tank is not exposed to any light because there are no windows were I have my fish tank. The water temperature is always between 68 - 80 degrees. I have the tank filtered with a 30 gallon filter and I do regular water changes of approximately 20-30% every week.

The problem is that I got a couple of plants (a week ago) for the tank because I decided to have some plants. I got some anacharis and since then I have been turning on the fluorescent lamp for 10-14 hours each day. The plants don't seen to grow any bigger or look healthy either. Some leaves are yellowish, some are bitten by my goldfish and others just fall right off the stem. So I was wondering if it was my tank's fault that the plants aren't growing because in the past it couldn't support the growth of algae.

I bought fertilizer (Plant Gro) yesterday and poured a couple of drops inside the tank but I still don't see any difference in the plants or any signs of algae growth.

Maybe my fluorescent lamp isn't strong enough or maybe my plants need more carbon dioxide. I don't think it's a matter of the nutrients that are inside the tank because goldfish produce a lot of wastes that are useful for my plants plus I added fertilizer.

Another question. Since I'm using fertilizer, should I take the carbon out of my filter. I have a whisper filter. The one's you hang on the back of the tank.

Yesterday I also took a couple of anacharis in a separate plastic tank that I have and I let it sit near the window where there is light with some gravel from my tank, water and some drops of the fertilizer. Unfortunately, it has been raining these past days and there is no direct sunlight.

Thanks for looking at my post and hope you can help me.
AlphaHydrox is offline   Reply With Quote
Old 08-21-2007, 11:50 AM   #2
 
Falina's Avatar
 
You should def take the carbon out the tank. That may very well be the reaosn they're not doing well. The carbon removes all the nutrients that a plant uses.
Falina is offline   Reply With Quote
Old 08-21-2007, 12:15 PM   #3
 
Wouldn't removing the carbon out of the filter have any negative effects?
AlphaHydrox is offline   Reply With Quote
Old 08-21-2007, 12:27 PM   #4
 
Falina's Avatar
 
I would say no. I'm not a great fan of it anyway and many folk here aren't. It's good if you need to remove tannins or meds but other than that some filter floss works better IMHO.
Falina is offline   Reply With Quote
Old 08-21-2007, 01:16 PM   #5
 
What about the lights? Do you think I need a lamp with more wattage?
AlphaHydrox is offline   Reply With Quote
Old 08-21-2007, 02:27 PM   #6
 
fish_4_all's Avatar
 
It could very well be the lighting that isnot allowing the plants to grow, that and the lack of nutrients. I know you shoulod have plenty of nitrates and phosphates but micro nutrients are very important and you need to dose the needed amount so the plants can even have a chance to thrive.
The yellowing is a classic sign of iron deficiency.
fish_4_all is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help!! Chaetomorha algae won't grow!! turk86 Beginner Saltwater Aquariums 7 06-06-2009 02:35 PM
How to grow algae? SolaceTiger Beginner Freshwater Aquarium 9 11-16-2008 08:16 PM
Got a new aquarium and want to grow plants beaufred Beginner Planted Aquarium 9 04-03-2008 06:16 PM
How to grow live plants? hookedonfishtanks Beginner Planted Aquarium 2 02-27-2008 07:15 PM
What rock to grow algae on musho3210 Beginner Freshwater Aquarium 2 01-19-2007 03:45 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -5. The time now is 11:06 PM.