plants look horrible - Tropical Fish Keeping - Aquarium fish care and resources
Reply
 
LinkBack Thread Tools
post #1 of 17 Old 10-21-2011, 08:21 AM Thread Starter
Member
 
Unhappy plants look horrible

i have a few java ferns (slow growing?), one planted wisteria (looking surprisingly good), and a clump of water sprite in my tank. the water sprite looks pretty bad. it isn't dead, and it is growing new fronds occasionally, but it is rather brown. i'll try to get a picture of it in a little while.

i started using flourish comprehensive last week, dosing once a week. my light (the bulb that came in my hood) is on 10 hours a day, i have rather high nitrates, and no algae. i don't know if my pleco is getting it before i can see it or if it simply isn't growing. i took the charcoal out of my filter two weeks ago.

any one have any idea why my plants aren't doing well? i'm going to buy some more plants hopefully today, but i don't want them to all die/look horrible too.

**I freely admit that most of the information I share I have learned from other people on this forum and am simply repeating. I thank you for sharing your knowledge and ask that if I say anything incorrect someone will kindly correct me**
KendraMc is offline  
Sponsored Links
Advertisement
 
post #2 of 17 Old 10-21-2011, 10:14 AM
Member
 
Boredomb's Avatar
 
Kendra can you tell us what the bulb says on it? I know the bulbs I got with my hood were not good at all for growing g plants. I also have heard of some getting bulbs in their hoods that were full spectrum bulbs which were ok.

Java ferns are slow growers you are correct there. Water sprite is a stem plant the best I can remember people talking about it. I know some people use it as floating plant and it works good. Watch out with the wisteria. It can demand moderate to high lights.
Boredomb is offline  
post #3 of 17 Old 10-21-2011, 11:25 AM Thread Starter
Member
 
all it says is F18T8. i don't know what that actually means, but in a previous thread Byron told me that it is good enough for low light plants.

and yeah, i know the wisteria could fade and die any time, it is the last of i think 4 i started with, but it is currently looking better than my water sprite, which is floating and is supposed to be one of the easier plants to grow.

**I freely admit that most of the information I share I have learned from other people on this forum and am simply repeating. I thank you for sharing your knowledge and ask that if I say anything incorrect someone will kindly correct me**
KendraMc is offline  
post #4 of 17 Old 10-21-2011, 11:33 AM
Member
 
Boredomb's Avatar
 
I have never grown water sprite but as you said I have heard it is easy. What brand is the light/hood. I am wondering if the light is the issue? I am thinking so but since you just started with the fertilizer last week that might also have something to do with it. It can take some time to correct the lack of nutrients with the plants. I would wait and see what Byron has to say about it since he had previously said the lights were ok. Also a pic would help a lot.
Boredomb is offline  
post #5 of 17 Old 10-21-2011, 11:39 AM Thread Starter
Member
 
i was using some cheap liquid fert before, but when that ran out i got what people seem to think is one of the best.

the light is marineland.

**I freely admit that most of the information I share I have learned from other people on this forum and am simply repeating. I thank you for sharing your knowledge and ask that if I say anything incorrect someone will kindly correct me**
KendraMc is offline  
post #6 of 17 Old 10-21-2011, 11:49 AM
Member
 
Boredomb's Avatar
 
I did a quick search on your Bulb F18T8. From what I can tell it should be a daylight bulb. It doesn't say that on yours through right? The F18T8 also means its an 18w T8 bulb the best I can tell. If this is the case it should be fine growing low light plants. So I am kinda confussed now. Is it just the water sprite you are having problems with? How is the Java fern? Is it showing any problems with the leaves?
Boredomb is offline  
post #7 of 17 Old 10-21-2011, 11:50 AM Thread Starter
Member
 
it really looks like the water sprite is the worst, though i'm not sure with the java ferns. they aren't dying, but they aren't growing/sprouting any more. i got a few baby ferns in the beginning, but none since then.

**I freely admit that most of the information I share I have learned from other people on this forum and am simply repeating. I thank you for sharing your knowledge and ask that if I say anything incorrect someone will kindly correct me**
KendraMc is offline  
post #8 of 17 Old 10-21-2011, 11:54 AM
Member
 
Boredomb's Avatar
 
Sorry for so many questions. Does the water sprite have brown leaves? Or algae on it? I know I sometimes have problems with black algae with my plants that are floating. Since they are so close to the light.
Boredomb is offline  
post #9 of 17 Old 10-21-2011, 11:56 AM Thread Starter
Member
 
brown leaves. no algae.

and questions are good, more questions=more information=better answers.

**I freely admit that most of the information I share I have learned from other people on this forum and am simply repeating. I thank you for sharing your knowledge and ask that if I say anything incorrect someone will kindly correct me**
KendraMc is offline  
post #10 of 17 Old 10-21-2011, 12:02 PM
Member
 
Boredomb's Avatar
 
Okay to be honest here I don't know. You said you were dosing a different type of fertilizer previous to flourish. Did you notice the sprite turing brown when you changed to flourish or before?
Boredomb is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome