Velvet of the Living Dead! It won't go away!
Tropical Fish

Tropical Fish Keeping - Aquarium fish care and resources » Freshwater Fish and Aquariums » Beginner Freshwater Aquarium » Velvet of the Living Dead! It won't go away!

Velvet of the Living Dead! It won't go away!

This is a discussion on Velvet of the Living Dead! It won't go away! within the Beginner Freshwater Aquarium forums, part of the Freshwater Fish and Aquariums category; --> I have a 10 gal fish tank. My fish has been sick for the last 2-3 weeks.My betta was acting a little sad. I ...

Check out these freshwater fish profiles
False Network Catfish
False Network Catfish
Denisons Barb
Denisons Barb
Reply
LinkBack Thread Tools vBmenu Seperating Image Search this Thread vBmenu Seperating Image
Velvet of the Living Dead! It won't go away!
Old 11-15-2011, 11:05 PM   #1
 
liz26914's Avatar
 
Velvet of the Living Dead! It won't go away!

I have a 10 gal fish tank. My fish has been sick for the last 2-3 weeks.My betta was acting a little sad. I took a flashlight and found a smal rust spot where the body meets the fins by his belly. Soon after, My guppies and platy started doing the itchy dance. Rubbing against the plants and gravel and acting like they were on a sugar high. I assumed it was velvet or some kind of parasite. I borrowed coppersafe from my friend, did a 100% water change and dosed my tank with the coppersafe. A week later, the water was green and ther was no change with the fish. I did a 40% water change and put a teaspon of coppersafe into to my tank. The water looked clean again, but it turned green again and no change with the fish. I did another 40% water change and another teaspoon of coppersafe. This time I put a blanket over the tank so that the velvet, which was suppose to be algea, wldn't b able to grow. In a couple of days, the water was green again. I did some research and found out that the water conditioner, stress coat, stopped the meds from working. So i went to Petco and got a different water condtioner, Aqueon Water conditioner. I did a 100% water change, used the new water conditioner and used coppersafe again. Its been several hours and I might be paranoid but I thnk the water looks a little yellowish. Again i might just b paranoid and it could be the lighting.My question is does aqueon water conditioner have the same thing stress coat doess that stops coppersafe from working? Am I doing something wrong? I have 3 heaters in ther and the temp is in the high 70s. I havnt seen any of the fish doing the itchy dance, but I havnt been watching them the whole time. Also, my dorm room smells really bad. Is this because of the velvet in the tank or just because I have fish
liz26914 is offline   Reply With Quote
Old 11-16-2011, 12:26 AM   #2
 
copper safe is copper sulfate and AFAIK isn't effected by most water conditioners. Your post is a little confusing though. It does sound like you may have velvet, but you also seem to be having an algae bloom which are two different problems. The coffer safe is going to have no impact on the algae bloom. Also copper safe has a really long treatment time, TBH I've never had very good results with it at the given dosage. I prefer to use aquariasol which has the same ingredient but seems to dose a higher concentration.

A fish tank should not smell, but they can if there is a bacterial or algae bloom. It would be helpful if you could post more information about your tank, including size, stock, maintenance, and water parameters.
Mikaila31 is offline   Reply With Quote
The Following User Says Thank You to Mikaila31 For This Useful Post:
liz26914 (11-16-2011)
Old 11-16-2011, 08:34 PM   #3
 
I use AlgaeFix for algae blooms.It works great.
snafudude is offline   Reply With Quote
The Following User Says Thank You to snafudude For This Useful Post:
liz26914 (11-16-2011)
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
What does everyone do for a living? Amphitrite Off Topic Discussions 32 03-29-2007 11:06 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -5. The time now is 11:52 AM.