tiny floating particles. - Tropical Fish Keeping - Aquarium fish care and resources
 
LinkBack Thread Tools
post #1 of 8 Old 03-28-2011, 07:47 AM Thread Starter
New Member
 
Unhappy tiny floating particles.

This is driving me insane. I have extremely tiny particles floating in my aquarium water.(It's not milky.) The tank has been up and running for months, and I've done partial water changes as recommended. It's a 16 gallon tank from a kit, and I use the filter that came with it: the Aqueon Quiet Flow 20. At first, I thought maybe I had failed to rinse my gravel thoroughly. But if that was the case, wouldn't all those particles either sink, or get caught in the filter, by now?

Any thoughts on how to get clear water?
Jenna28 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 03-28-2011, 10:13 AM
It is probably just little air bubbles. If not I have no idea.

38 gallon :
Pelvicachromis Taeniatus Nigerian Red not yet breeding pair
4 Pangio Kuhli
12 Hemmigrammus Bleheri
2 Botia Lohachata
1 Botia Straita
1 Ancistrus Sp.
6 Poecilia Reticulata




The Wet Spot Portland Oregon!!!!!!

ADA: Do!aqua Iwagumi 10 gallon size!
7 Clown Killies
7 Ghost shrimp
Christople is offline  
post #3 of 8 Old 03-28-2011, 12:01 PM Thread Starter
New Member
 
I thought that might be the problem... so I turned off the air pump for a few hours, but it didn't help.
Jenna28 is offline  
post #4 of 8 Old 03-28-2011, 12:15 PM
then I don't know.

38 gallon :
Pelvicachromis Taeniatus Nigerian Red not yet breeding pair
4 Pangio Kuhli
12 Hemmigrammus Bleheri
2 Botia Lohachata
1 Botia Straita
1 Ancistrus Sp.
6 Poecilia Reticulata




The Wet Spot Portland Oregon!!!!!!

ADA: Do!aqua Iwagumi 10 gallon size!
7 Clown Killies
7 Ghost shrimp
Christople is offline  
post #5 of 8 Old 03-28-2011, 01:35 PM
Member
 
lorax84's Avatar
 
Without seeing a picture it is hard to tell you how to solve the problem. All tanks are going to have some kind of particulates floating around occasionally.
lorax84 is offline  
post #6 of 8 Old 03-28-2011, 04:19 PM
Yes I have some to.

38 gallon :
Pelvicachromis Taeniatus Nigerian Red not yet breeding pair
4 Pangio Kuhli
12 Hemmigrammus Bleheri
2 Botia Lohachata
1 Botia Straita
1 Ancistrus Sp.
6 Poecilia Reticulata




The Wet Spot Portland Oregon!!!!!!

ADA: Do!aqua Iwagumi 10 gallon size!
7 Clown Killies
7 Ghost shrimp
Christople is offline  
post #7 of 8 Old 03-28-2011, 06:07 PM
Try running polishing pads in your filter. The ultra-fine pads usually last for about 10 days before you have to remove them but it catches the vast majority of the particles in my tank. I've only had to use it once, wasnt sure that the particles were either, maybe my calcium stains were dissolving and pieces were floating around, anywho, the pad solved my problem and my particles haven't come back.
SinCrisis is offline  
post #8 of 8 Old 03-30-2011, 01:35 AM
Rip
Member
 
Rip's Avatar
 
i have a similar Aqueon kit for a 10 gallon tank, and i have a smaller version of the filter you have. if it is air bubbles, just try increasing or decreasing the amount of water slightly to raise the level a bit. sometimes, in my tank if the water level is at a certain point, the water runs into the tank, and trickels off the blue plastic piece filter guard thingy, and causes a ton of air bubbles. like if you look at it from below, you can't even see the fish food on the water surface.

Last edited by Rip; 03-30-2011 at 01:38 AM.
Rip is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Particles in my water. BrandonJ Beginner Freshwater Aquarium 5 02-07-2011 08:02 PM
Little inch worms and tiny tiny bugs?!?!?! TexasTanker Beginner Freshwater Aquarium 8 05-19-2010 12:38 PM
Tiny particles in my water.... KSASTER2 Beginner Freshwater Aquarium 3 04-07-2010 09:46 PM
white particles? solareclipsed Beginner Freshwater Aquarium 7 04-27-2007 08:20 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome