tetra whisper making noise - Tropical Fish Keeping - Aquarium fish care and resources
 
LinkBack Thread Tools
post #1 of 4 Old 10-30-2009, 03:40 PM Thread Starter
New Member
 
tetra whisper making noise

I've had a issue latley with my whisper HOB making grinding sounds. I thought it was the impeller so I drained the hob and cleaned the impeller and the well it sits in. I am still getting the noise and the motor is warm (not hot). Thinking it was the intake sucking up the occasional air pocket from my bubbler I turned off the bubbler...still grinding away. anyone have any suggestions on this?
Jerryed is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 11-01-2009, 04:36 AM
Member
 
bettababy's Avatar
 
I would first suggest once again removing the impeller and checking it for dents, bent areas, or other damage. Typically the whisper filters rattle as you described when the impeller magnet has been damaged or the shaft has been bent. You might want to try ordering a new impeller for it. If your lfs doesn't stock the part you can contact the company to find somewhere that does.

Dawn Moneyhan
Aquatics Specialist/Nutritionist
Juneau, WI
bettababy is offline  
post #3 of 4 Old 11-01-2009, 11:59 AM Thread Starter
New Member
 
Well the impeller is pristine. straight as an arrow and no damage. I thought the little retaining rinng in the intake tube might be the culprit. Im gonna check that tonight when I do my weekly PWC. Im gonna lube the impeller seat with some petroleum jelly and see what happens.
Jerryed is offline  
post #4 of 4 Old 11-01-2009, 02:54 PM
Member
 
bettababy's Avatar
 
Sounds good.

Dawn Moneyhan
Aquatics Specialist/Nutritionist
Juneau, WI
bettababy is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
filter making a lot of noise ~ help! vinoth1465 Freshwater Aquarium Equipment 6 11-03-2007 11:19 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome