t5s not working?
Tropical Fish

Tropical Fish Keeping - Aquarium fish care and resources » Freshwater Fish and Aquariums » Beginner Freshwater Aquarium » t5s not working?

t5s not working?

This is a discussion on t5s not working? within the Beginner Freshwater Aquarium forums, part of the Freshwater Fish and Aquariums category; --> so i just got my th fixture and my t5 ho lights for them. both the fixture and light are the t5 ho. ive ...

Check out these freshwater fish profiles
Platy
Platy
Blind Cave Tetra
Blind Cave Tetra
Reply
Old 02-28-2013, 03:28 PM   #1
 
MoneyMitch's Avatar
 
t5s not working?

so i just got my th fixture and my t5 ho lights for them. both the fixture and light are the t5 ho. ive never had t5s before but had them mailed. the tubes were shipped seperate from the lights. i went to install and i can hear something loose in there when i tuip the bulb end to end is this the fillament thats broke? or is my fixture faulty. i have tried to install the tubes in the fixture and they dont even flicker. so the thing bounching aroudn in there good or bad? i ordered from dr fostersmith and they are sneding me new but might be in vain if t5s alwyas have something loose in them?
MoneyMitch is offline   Reply With Quote
Old 02-28-2013, 04:11 PM   #2
 
MoneyMitch's Avatar
 
wow bonehead moment, turns out i have to put the lights in and turn them 3/4 turn to lock them in, there is one bulbs that was shaking and does not work. but i plug the fixture in it turns on for a few seconds then right off. turns out the glo dual fixture will only run with 2 bulbs in it and it wont function properly with only 1 bulb. just a heads up to anyone that gets a glo fixture. i bought the fixture in "like new" condition from amazon for 75$ the box came all beat up so i thought the fixture was toast but its not. PHEW thank you google search. so easy to panic when i order fragile things in the mail that are expensive. (ps when u buy from amazon get it from amazon not a individual seller) not as good return policy and your stuck with the return shipping. by the way drfostersmith.com is sending new lights today and a mailing slip for the broken light. the lady on phone was polite and very nice and helped me well. highly reccomend drfostersmith for any onlien purchases
MoneyMitch is offline   Reply With Quote
Old 02-28-2013, 10:24 PM   #3
 
glad you got it figured out. Also most bulbs do rattle a bit when cold/new as some of the mercury/ some other elements in side the tube are often condensed in a little tiny ball at first. This is vaporized to start the bulb. It usually reforms every time the bulb cools down, but as the bulb ages its less and less likely. Not all rattle, but more do then not .
Mikaila31 is offline   Reply With Quote
Old 03-01-2013, 03:00 PM   #4
 
MoneyMitch's Avatar
 
just tried the bulb with rattle, and still wont fire up. the other one does just fine. pretty sure it was damaged during shipping.
MoneyMitch is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
DIY co2 not working? okiemavis DIY Aquarium 6 05-05-2008 05:24 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -5. The time now is 03:41 PM.