Suppose to be just a normal WC day but noo...... - Tropical Fish Keeping - Aquarium fish care and resources
Reply
 
LinkBack Thread Tools
post #1 of 18 Old 01-15-2012, 02:12 PM Thread Starter
Member
 
Boredomb's Avatar
 
Suppose to be just a normal WC day but noo......

Everything that could have gone wrong did (well probably not but just as bad). So I told my wife today I HAD to clean the tanks which she was fine with but she was getting a little moody so I kicked her out of the house to go shopping with my sister LoL. Then I proceeded to clean my 55 gallon tank. I trimmed some plants did a slight gravel vacuum to get some dead leaves out and durning the process I drained half the tank like always.

Then the trouble starts when I went to but some Dechlorinator in the tank so I could fill it back up I couldn't find it ANYWAY!!!!! So now I have no Dechlorinator no car and stuck with the kids. So I call the wife asking if she had seen a small bottle of Prime. Her response "What is that? " Arghhhh so at this point I am getting a little mad (mostly at myself) cause I have a half empty tank and now way to fill it back up. Well I call her back tell her to puck some up so I can before she makes it to.the store I Finally found the bottle. It was not in a place I put it last though. So I call the wife and she says " Oh that bottle yeah I put next to the sink." Arggghhhhhh!!! So I calm down and proceed to take apart my filter while the tank is filling up just have a hose come apart and soak me in the face!! So now I have my thumb stuck in a broke hose and trying to figure out how to fix it (it started a siphon and was draining the tank again!). Well I take my thumb out for a second and yes it is pouring water out and force the two hoses together for the time being. Well now everything is fixed and put back together. While I am standing infringe of the tank looking I hear a strange buzzing sound thinking to myself that's odd. I go looking and it is my timer for the lights. Now it isn't just a timer it is surge protector also and everything plugs into it.
2012-01-15 14.34.49.jpg

I unplugged it and picked it up and water came out of it.
it must have gotten water in it from the hose that broke on me. So now I can only plug up my lights and the filter as that's all I can get into the wall socket.

I took the timer/surge protector apart and blow it out with a hair dryer and letting it sit hoping it will work like it is suppose to again. It was working when it was buzzing just now like it was suppose to be as the clock wasn't on.
2012-01-15 14.42.54.jpg

Anyone else have days like this or is it just me?????
Boredomb is offline  
Sponsored Links
Advertisement
 
post #2 of 18 Old 01-15-2012, 03:49 PM
TFK Moderator
 
Romad's Avatar
 
Oh man - that sucks :( I'd say forget the lights for now and plug in the heater(s) and filter into the wall sockets.

If it makes you feel any better, my man human just spilled a big glass of red wine on our beige carpet. For like the third time this year. I'm trying to get him to love white instead LOL.

So, yeah, even though entirely different situations, this afternoon has been challenging and you're not alone.

Animal testing is a terrible idea; they get all nervous and give the wrong answers.
Romad is offline  
post #3 of 18 Old 01-15-2012, 03:57 PM Thread Starter
Member
 
Boredomb's Avatar
 
Red wine on beige carpet ohhh man that's a mess for sure!!

I thought about the heater instead but the house stays at 74 and without the heater the tank stays about the same. With the heater I keep it at 78 soo didn't think 4 would hurt that much for a short time. The surge part is working again just not the timer side. So I could plug it back up and just use that side till I can get another one.
Boredomb is offline  
post #4 of 18 Old 01-15-2012, 04:23 PM
TFK Moderator
 
Romad's Avatar
 
Sounds like a plan. Good luck with the temporary setup situation :)

Animal testing is a terrible idea; they get all nervous and give the wrong answers.
Romad is offline  
post #5 of 18 Old 01-15-2012, 04:33 PM
Member
 
willow's Avatar
 
you really are not alone,
i left a tank draining one time,sure the hose wouldn't fall out of the tank............
yeah right,it did,it got so low my angel fish was flapping on the gravel,he damaged
himself badly and i lost him some time after,not to mention a soggy carpet.that was a
juwel 96.......the tank of doom if anyone remembers.
another time i came back from holiday and my filter had burnt out,most of the fish had died,
the gravel was a heaving squelch of all things dead,and that one made me cry,coz i lost
my clown loaches to that one,and that was the big filter for the 4ft tank.
oh and i found a dead frog whilst moving the furniture ready for decorating,i lost him some time back,
so he was a virtual fossil
just thought i'd try and make you feel a little better lol

when you set up a new tank,hide an extra
sponge or two behind some decor,that way you have
something seeded for you next filter.
willow is offline  
post #6 of 18 Old 01-15-2012, 05:06 PM Thread Starter
Member
 
Boredomb's Avatar
 
WOW I really should proof read before I post stuff!!!! LMAO well y'all got the point anyways.
Thanks Romad and Willow atleast I know its just not me with this stuff.
Boredomb is offline  
post #7 of 18 Old 01-15-2012, 07:46 PM Thread Starter
Member
 
Boredomb's Avatar
 
0-2

Soo after the mess with the 55 gallon was taken care of I went to do my 10 gallon tank.
I siphoned out the water redone the tank. Had real bad algae or something. So when I finally get it some what Ok. I went to fill it up. Now I just use a bucket with a handle to fill this tank up since it is only 10 gallons. Well during the very first bucket of water the stupid thing broke. Yes the bucket broke with water in it! So water gets all over me again and ............ yes you guessed it my OTHER surge protector. Now what are the odds of that happening in the same day. Please someone tell me? LoL At this point I am cussing mad! That is 2 surge protectors in one day. Both still kinda work but both need replacing now.
Boredomb is offline  
post #8 of 18 Old 01-15-2012, 07:58 PM
zof
Member
 
zof's Avatar
 
Things can only get better from here! Well unless you have another surge suppressor you haven't drenched yet.
zof is offline  
post #9 of 18 Old 01-15-2012, 08:02 PM Thread Starter
Member
 
Boredomb's Avatar
 
Quote:
Originally Posted by zof View Post
Things can only get better from here! Well unless you have another surge suppressor you haven't drenched yet.
Nope don't have anymore to drench. I pretty much took care of all of them today. LoL
Boredomb is offline  
post #10 of 18 Old 01-16-2012, 03:15 PM
Member
 
willow's Avatar
 
i think it's a sign...........

when you set up a new tank,hide an extra
sponge or two behind some decor,that way you have
something seeded for you next filter.
willow is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
is this normal or not? dorabaker Anabantids 12 09-02-2010 07:22 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome