question about live plants - Tropical Fish Keeping - Aquarium fish care and resources
LinkBack Thread Tools
post #1 of 4 Old 03-30-2011, 02:05 PM Thread Starter
New Member
blueseyes109's Avatar
question about live plants

My tank has been up and running for a little over 6 months now and I recently added live plants to it. After I did this the water turned very cloudy and has stayed like that for about 3 or 4 days. Was it the plants that caused this or could it be something else?
blueseyes109 is offline  
Sponsored Links
post #2 of 4 Old 03-30-2011, 02:38 PM
DKRST's Avatar
Perhaps you stirred up some detritus in the substrate when you were planting? I'm assuming it's still cloudy? Any color to the cloudiness - white, green, brown? Could you post more information please, including what type of substrate, filter, lighting, etc.? Do you have any water parameters you can share (pH, ammonia, nitrate, nitrites)?

This information will allow folks to get a better idea of your issue.
DKRST is offline  
post #3 of 4 Old 03-30-2011, 02:46 PM
DKRST's Avatar
oops - ignore this post, hit the wrong key!
DKRST is offline  
post #4 of 4 Old 03-30-2011, 03:04 PM
redchigh's Avatar
Indeed, we need more information..

But no, it's extremely unlikely that the plants had anything to do with it.

Originally Posted by Christople View Post
^^ genius

Soil Substrates Guide:
Part 1
--------- Part 2

redchigh is offline  

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome