please help with another question about my tank - Tropical Fish Keeping - Aquarium fish care and resources
 
LinkBack Thread Tools
post #1 of 4 Old 07-13-2010, 03:15 AM Thread Starter
New Member
 
Salix's Avatar
 
please help with another question about my tank

So yesterday I made a big mistake while doing a water change. The freshwater I put in, I forgot to add the water conditioner to take out all of the bad things that makes tap water unsafe. My tank started to cycle all over again, or at least that's what I thought. Now almost everything in the tank except for the fish, filter, and heater is covered in a white film.

Not only this, but the tank has an awful odor coming from it that smells kind of like sulfur but not as strong. And I'm not talking about when I open the lid and stick my face close to the water. I mean standing about two or three feet away I can smell it.

This afternoon I checked the paramiters and everything was normal (ammonia 0, nitrite 0, pH 7.4, high pH 7), except for the nitrates which are low because I accidentally added unconditioned tap water yesterday. I did a 20% change by siphoning the gravel and most of the matter I pulled up was this white fuzzy stuff that is all over the surface gravel.

I didn't have the florescent light on at all today except for when I took the pictures just in case it's some type of fungus or something. I also did a salt bath after the water change because I heard that it can help kill fungus but it doesn't seem to be helping at all. The fish are picking at the stuff that's on the fake plants and even their waste is white. They don't seem to be stressed but I'm worried about what could happen to them, especially to their digestive systems. Does anyone know what this stuff could be and how to get rid of it?
Attached Images
File Type: jpg IMG_4575.jpg (104.1 KB, 23 views)
File Type: jpg IMG_4574.jpg (89.4 KB, 23 views)
Salix is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 07-13-2010, 04:06 AM
Member
 
1077's Avatar
 
Am confused, Is this the tank that you are using shrimp to cycle? If so there should be no fish for they will produce the ammonia to establish the beneficial bacteria.
You should not use fish and shrimp to begin the cycling.

The most important medication in your fish medicine cabinet is.. Clean water.
1077 is offline  
post #3 of 4 Old 07-13-2010, 02:38 PM Thread Starter
New Member
 
Salix's Avatar
 
No, this isn't the tank with the shrimp in it, that's a new 45 gallon I just got a couple weeks ago. This is my 10 gallon that I've had for a little over a year.
Salix is offline  
post #4 of 4 Old 07-14-2010, 01:15 AM
Member
 
1077's Avatar
 
Bad smells coming from an established tank are often indication that filter material needs cleaning and perhaps substrate could use more frequent cleaning with gravel vaccum.
White fluffy stuff could indeed be fungus that forms on bits of uneaten food as bacteria begins to work on it.
Might consider reducing amount of food offered, vaccum one third to one half of the substrate with each weekly water change, and would try to remember to always add dechlorinator to the new water before it enters the tank.
If indeed the 10 gallon has been up and running with fish for a year, then borrowing a bit of mature filter material from the 10 gallon ,will help jumpstart the (cycling) process in your 45 gallon.
Is called seeding a tank and can shorten the (cycling) process in your new tank considerably.

The most important medication in your fish medicine cabinet is.. Clean water.
1077 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Question about a 55 gal tank Spoon Freshwater Aquarium Equipment 15 03-15-2009 03:58 AM
a lighting question and a tank question beetlebz Freshwater Aquarium Equipment 2 12-12-2007 11:14 PM
I Got My Tank: Now I Have One Question.... Howl52 Fish Breeding 2 04-17-2007 09:02 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome