New tank less than a week old, weird algae? - Tropical Fish Keeping - Aquarium fish care and resources
 1Likes
  • 1 Post By candymancan
 
LinkBack Thread Tools
post #1 of 5 Old 08-31-2013, 12:30 PM Thread Starter
New Member
 
New tank less than a week old, weird algae?

so i decided to dig out my 60gallon tank and set it up in my son's room for him, i have had the tank running for just under a week, it has a undergravel filter with 2 powerheads and a HOT Magnum 250.
we bought some new decor from petsmart and i reused some from a past tank i had. i now have this algae(i think?) i took lots of photos let me know what you think it is!

http://s666.photobucket.com/user/Rya.../library/algae
Kroth is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 08-31-2013, 07:13 PM
Member
 
GwenInNM's Avatar
 
Quote:
Originally Posted by Kroth View Post
so i decided to dig out my 60gallon tank and set it up in my son's room for him, i have had the tank running for just under a week, it has a undergravel filter with 2 powerheads and a HOT Magnum 250.
we bought some new decor from petsmart and i reused some from a past tank i had. i now have this algae(i think?) i took lots of photos let me know what you think it is!

http://s666.photobucket.com/user/Rya.../library/algae
I'm guessing the beginning of hair algae. Not good stuff too have. May sort itself out as your tank matures. It's usually caused by an imbalance of light and nutrients. I'm not good about causes of algae.

Just because animals can't talk, does not mean they should not be heard
GwenInNM is offline  
post #3 of 5 Old 09-01-2013, 01:16 AM
That isn't hair algae I don't think.. Is the tank cloudy ? That stuff is the just from the cycle process its actually just bacteria building up (a good sign).. It will go away in 2-4 weeks. Just do daily water changes 15-25% water, and make sure you use prime water conditioner if you have city tap water with chlorine in it.. If you have fish in the tank deff do water changes to keep the ammonia and nitrites from the cycle process from killing them.. Do you have an API master test kit ? They can be kinda pricy but SOO worth it.

You can get some API Suplimental bacteria from Petco or Petsmart and use IMO 2x the recommended dose to help speed up the cycle.. Also adding food in the tank to create ammonia for the bacteria to eat and spread in the tank faster is a good idea too
GwenInNM likes this.

Last edited by candymancan; 09-01-2013 at 01:23 AM.
candymancan is offline  
post #4 of 5 Old 09-01-2013, 11:03 AM Thread Starter
New Member
 
I have a test kit, but I lost the card and instructions for it, also the tank is crystal clear. There are no fish in the tank yet
Posted via Mobile Device

Last edited by Kroth; 09-01-2013 at 11:05 AM.
Kroth is offline  
post #5 of 5 Old 09-02-2013, 05:56 PM
You don't need the instructions.. The other bottle you gatta shake is the Nitrate #2 bottle.. shake it like crazy for 30 seconds, and then shake the tube for 1 minute.. don't use the caps to hold the water when you shake them as stuff leaks out use your fingers rinsed in the tanks water.

My betta tank has the same clear stuff growing on stuff in there.. Itll go away... Now if it is hair algae and its only on the driftwood.. I am unsure what to do about that stuff because I have never had it
candymancan is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
New tank less than a week old, weird algae? Kroth Tropical Fish Diseases 3 09-27-2013 04:58 PM
Weird Algae in 55 Gallon Blaxicanlatino Beginner Freshwater Aquarium 5 03-22-2012 01:52 PM
Weird Algae growing on glass... redchigh Beginner Planted Aquarium 3 02-11-2012 04:09 PM
Algae vs. other plants - If it's ok to plant a tank, what's the prob. with Algae? KatG Beginner Freshwater Aquarium 5 11-08-2010 08:46 AM
Is it weird that I want Algae in my tank? Inga Beginner Freshwater Aquarium 14 08-14-2010 06:03 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome